Allg. Firefox3 nicht mit rtsp Protokoll verknüpft

★ Themenstarter ★
Mitglied seit
16.01.2008
Beiträge
16
Renomée
0
Guten Tag,

Ich habe ein kleines Problem mit Firefox 3 und hoffe ihr könnt mir kurz helfen.

Eine Freundin hat mir immer Links von (mobile?!) YouTube geschickt.

http://m.youtube.com/watch?v=9q-uuFm4oAw&client=mv-google&gl=JP&hl=ja&guid=ON&warned=True

Deren Videos (3GP) kann ich seit heute aber leider nicht mehr öffnen oder abspielen.

Habe dazu immer auf das Bild (links oben) des Videos geklickt, danach hat sich der Download Manager geöffnet und ich hatte die Wahl es zu speichern oder zu öffnen.
Hinter öffnen stand, das es mit VLC Media Player abgespielt wird. Nachdem die ca. 1-3 MB geladen waren, wurde es mit VLC Player abgespielt.
Jetzt zeigt mir Firefox nur noch die Fehlermeldung;
"Firefox weiß nicht, wie diese Adresse geöffnet werden soll, da das Protokoll (rtsp) mit keinem Programm verknüpft ist." an.
Habe Firefox auch schon neu installiert, hat aber nichts gebracht.
Irgendwelche Updates für Firefox, Windows etc hatte ich seit Tagen auch keine mehr. Installiert hatte ich auch nichts.

Bin echt überfragt ...

Mit Internet Explorer kann ich die Videos auch nicht öffnen, weiß aber nicht, ob das vorher überhaupt ging.

mfg

Bittersweet Life
 

Dalai

Grand Admiral Special
Mitglied seit
14.06.2004
Beiträge
7.373
Renomée
240
Standort
Meiningen, Thüringen
Geh mal in die Einstellungen unter Inhalt > Dateitypen > Verwalten und schau, ob dort der Dateityp 3gp aufgelistet wird. Wenn ja, dann kannst du dort das Verhalten von Firefox ändern, also was er mit diesen Dateien machen soll.

MfG Dalai
 
★ Themenstarter ★
Mitglied seit
16.01.2008
Beiträge
16
Renomée
0
Danke für die Hilfe, aber unter Einstellungen > Inhalt kann ich Dateitypen verwalten nicht finden.
Unter Einstellungen > Anwendungen steht bei Aktion hinter 3GPP-Inhalte VLC Multimedia Plugin (in Firefox) verwenden.
Gehen tut es aber trotzdem nicht.
Müsste er nicht wenigstens die Möglichkeit bieten, die Datei zu speichern, auch wenn er sie nicht abspielen kann?
Damit ich sie dann mit VLC Media Player von der Festplatte abspielen kann?!

mfg

Bittersweet Life
 

Dalai

Grand Admiral Special
Mitglied seit
14.06.2004
Beiträge
7.373
Renomée
240
Standort
Meiningen, Thüringen
Bittersweet Life schrieb:
aber unter Einstellungen > Inhalt kann ich Dateitypen verwalten nicht finden.
OK, dann wurde das mit Firefox 3.x umgebaut. Ich nutze noch Firefox 2, weil mir einige Sachen an der 3er nicht gefallen.

Bittersweet Life schrieb:
Unter Einstellungen > Anwendungen steht bei Aktion hinter 3GPP-Inhalte VLC Multimedia Plugin (in Firefox) verwenden.
Gehen tut es aber trotzdem nicht.
Dann schmeiß den Dateityp raus. Dann sollte er bei der nächsten Begegnung mit diesem Dateityp wieder fragen, was damit gemacht werden soll.

Bittersweet Life schrieb:
Müsste er nicht wenigstens die Möglichkeit bieten, die Datei zu speichern, auch wenn er sie nicht abspielen kann?
Nein, wenn dort drinsteht, dass er damit irgendwas machen soll (Abspielen mit irgendeinem Player) und nicht fragen soll, dann fragt er auch nicht.

MfG Dalai
 

Rabe

Admiral Special
Mitglied seit
17.08.2004
Beiträge
1.313
Renomée
94
Standort
LB
Bei Firefox 3 sind die "Dateityp" unter "Anwendungen" gelistet.
Bei mir verwendet Firefox, um 3GP Videos zu öffnen Quick Time 7.5.5.
 
Zuletzt bearbeitet:
★ Themenstarter ★
Mitglied seit
16.01.2008
Beiträge
16
Renomée
0
Sorry, aber es geht immer noch nicht.

Ich hatte jetzt bei Aktion hinter 3GPP 'jedes mal nachfragen' und auch mal 'Datei speichern' eingestellt.
Hat aber nichts gebracht.
Wenn ich mir die Anwendungs Details angucke, steht da das ich 3GPP Inhalte auch mit der vlc.exe abspielen kann,
aber auch wenn ich die einstelle, ändert sich nichts.
Wenn ich auf das Video klicke,bekomme ich immer noch;
"Firefox weiß nicht, wie diese Adresse geöffnet werden soll, da das Protokoll (rtsp) mit keinem Programm verknüpft ist."

@Rabe Quicktime scheine ich nicht auf dem Rechner zu haben,
kann es zumindest unter Aktion weder auswählen noch beim durchsuchen der Festplatte finden.

Woran kann es noch liegen?

mfg

Bittersweet Life

Edit:

Hab eben mal Quicktime 7.5.5. installiert und mit Aktion verknüpft, hat aber leider auch nicht geholfen.
 
Zuletzt bearbeitet:

OBrian

Moderation MBDB, ,
Mitglied seit
16.10.2000
Beiträge
17.036
Renomée
266
Standort
NRW
Der Thread ist zwar schon uralt, aber das Problem ist trotzdem leider noch aktuell (habe es auch gerade gehabt), daher der Vollständigkeit halber die Lösung, falls jemand per Google herfindet:

Für Firefox 3.5 und höher:

- in die Adressleiste about:config eingeben
- Rechtsklick -> "Neu" -> "Boolean" -> bei Name eingeben: network.protocol-handler.expose.rtsp -> bei Wert angeben: False
- beim nächsten Klick auf einen rtsp://...-Link wird man gefragt, womit man das öffnen möchte, dort den VLC-Player auswählen (üblicherweise unter c:\Programme (x86)\VideoLAN\VLC\vlc.exe) und auch nicht vergessen, den Haken "immer damit öffnen" anzuklicken.

Funktioniert mit entsprechender Anpassung natürlich auch für allen anderen Protokolle.

siehe auch http://kb.mozillazine.org/Register_protocol
 

Nebelraser

Redshirt
Mitglied seit
03.08.2013
Beiträge
1
Renomée
0
habe ich gemacht, hat auch nicht gefunzt.
Aber bei youtube wird ja zum Glück auch die Option "Desktop" angeboten, hatte ich erst übersehen.
 
Oben Unten