KUbuntu RAID0

Schattenreich

Grand Admiral Special
Mitglied seit
15.05.2006
Beiträge
6.275
Renomée
434
Standort
Landkreis Osterholz
  • THOR Challenge 2020
Hallo,

Ich versuche nach der anleitung https://gist.github.com/samrocketman/9677ca29e0fbaab8f8e55ebc3039172a KUbuntu auf ein software RAID0 zu instalieren aber klapt nicht nach dem neustart ist das raid 0 weg ich will auch nichts von daten sicherheit hören ect..

Als system habe ich ein laptop asus X72D mIt 2x ssd 512gb mit dem aktulen KUbuntu22
 
Die Anleitung ist für Ubuntu16 aus dem Jahr 2016.
Vermutlich hat sich da Einiges inzwischen geändert.
 
Was liefert denn
Code:
cat /proc/mdstat

Und ist das Raid auch in der fstab eingetragen?
 
Wie wird denn der PC gestartet? Per UEFI und direkt laden des Kernels oder per UEFI + GRUB?
Falls UEFI, wie hast du das mit der EFI Partition gehandhabt?

Generell ist kann das Verwenden eines RAID für die root Partition tricky sein, da es ja erst zusammengesetzt werden muss, bevor das System starten kann, während ein klassischer Bootvorgang von einem Start nur von einer Partition ausgeht.
GRUB kann das prinzipiell, auch über eine initrd lässt sich das bewerkstelligen, aber es ist halt nicht ganz einfach.

Ich würde im Allgemeinen daher eher empfehlen das System selbst auf eine einzelne Partition zu installieren und nur den Teil, den du wirklich als RAID0 haben willst (also /mnt/ultraschnelle-Partition o.ä.) dann als RAID0.
Dadurch gehst du besagten Problemen aus dem Weg und ein Defekt eines der Devices im RAID0 schießt dir auch nicht gleich das komplette System ab.
(Dass RAID0 nur für unkritische Daten eingesetzt werden sollte ist ja hoffentlich klar. ;))
 
Zurück
Oben Unten