Problem mit KOTOR

eden

Vice Admiral Special
★ Themenstarter ★
Mitglied seit
28.04.2004
Beiträge
895
Renomée
3
Habe da ein merkwürdiges Problem mit KOTOR.
Zuerst läuft das Spiel butterweich auf max. Details und 1280x1024, 2xAA und 2xAF, aber sobald ich auf dem zweiten Planeten auf den man kommt etwas "weitblick" habe, bricht die FPS ein und das ruckeln geht los. Veringern der Auflösung und veringern von Details, sowie abschalten von AA und AF brachten leider nichts.
Weiß vielleicht jemand abhilfe?
 

Thorgods_hammer

Commodore Special
Mitglied seit
19.06.2004
Beiträge
435
Renomée
2
Kann es sein das du Kotor 2 meinst?
Da gibt es einen Fehler im Spiel, den man aber wohl mit einem Patch beheben kann!
Hatte nämlich das gleiche Problem :[ ! Ich weiß aber ob es funzt?!

Patch 1

Patch 2
 

GSachse

Grand Admiral Special
Mitglied seit
24.02.2002
Beiträge
2.859
Renomée
9
Standort
Halle
Thorgods_hammer schrieb:
Kann es sein das du Kotor 2 meinst?
Da gibt es einen Fehler im Spiel, den man aber wohl mit einem Patch beheben kann!
Hatte nämlich das gleiche Problem :[ ! Ich weiß aber ob es funzt?!

Patch 1

Patch 2
hast du ne ati ??
wenn ja mal den neusten catalyst probieren hat bei mir geholfen..
bei beiden teilen ;)
 

boidsen

Grand Admiral Special
Mitglied seit
21.11.2004
Beiträge
18.251
Renomée
153
Standort
Negnidürtressaw
Yepp - Cat 5.4 hilft! Der erste Patch nützt da nix, beim zweiten weiß ichs nich... (hab bisher nur den ersten druff...).
Alternative:
Just in case anyone hasn't seen it yet, the answer to the most common problem I've seen:

On Dantooine or in other smoky areas, the game can slow to a crawl. This can be fixed by adding the line

Disable Vertex Buffer Objects=1

Under the [Graphics Options] section in the swkotor2.ini file. This should increase performance greatly.
(Zitat)
 

Thorgods_hammer

Commodore Special
Mitglied seit
19.06.2004
Beiträge
435
Renomée
2
GSachse schrieb:
hast du ne ati ??
wenn ja mal den neusten catalyst probieren hat bei mir geholfen..
bei beiden teilen ;)

Jepp hab ich, siehe Sig!
Hab den 5.4 noch nicht drauf (gab es damals leider noch nicht), und dann hab ich mich so durchgekämpft (war ganz schön eklig)!
 

[M.o.C]Co

Cadet
Mitglied seit
20.07.2004
Beiträge
33
Renomée
0
Bie KOTOR hatte ich mit meiner 9800Pro keine Probs, aber mein Bruder mit seiner 9600XT. Allerdings kam das Spiel auf Dantooine bei KOTOR2 auch bei mir ins stocken. Die Patches haben nichts gebracht. Treiber kann ich mich jetzt auch nicht erinnern. Aber ihr spielt ja mit Euren Grakas in einer anderen Liga.

Disable Vertex Buffer Objects=1
verursachte bei mir einen Freeze --> also für mich auch keine Lösung.

Aber ich habe festgestellt, dass es irgendwie half, die Grafikeinstellungen ins total positive bzw. negative zu ändern (AA, AF, Gras; nur Auflösung behielt ich bei) und schon lief es wieder flüssig... *noahnung*
 

GSachse

Grand Admiral Special
Mitglied seit
24.02.2002
Beiträge
2.859
Renomée
9
Standort
Halle
bei kotor 2 funzte auch ein kleiner trick..
einfach das gras ein und oder aussschalten..
übernehmen und es ging..
bei kotor 1 funzte es komischerweise nicht *suspect*
 

boidsen

Grand Admiral Special
Mitglied seit
21.11.2004
Beiträge
18.251
Renomée
153
Standort
Negnidürtressaw
Also nochmal:
Bei mir (9700pro und 9800XT) klappts sowohl mit dem .ini-Hack, als auch ohne diesen und mitm 5.4er Catalyst und zwar bei KotoR1 und 2. Und sonst alles aufs höchste und an und 4-fach AA und 8-fach AF bei 1280x1024x32 (da kommt die 9700pro so langsam ins Schwitzen - uff ;D , die 9800XT schüttelts noch ausm linken Vertex Shader ;) ). Bei 1024x768x32 is eh kein Thema... Und ich hab da schon Ansprüche an die fps *great* --> Wenn ich ne Dia-Show will, pack ich lieber meinen alten Braun-Projektor aus :P

---->> Ja, ja - diese ATI-Treiber... :[ Jetzt kriegense langsam aber sicher Linux in ´n Griff, nu fehlt nur noch ne richtig gute OpenGL-Unterstützung - dann kann sich Nvidia aber gaaanz warm anziehen ;D ;D ;D
 
Zuletzt bearbeitet:

cr4wler

Admiral Special
Mitglied seit
02.09.2003
Beiträge
1.638
Renomée
5
problem is hier schon paar mal besprochen worden... Disable Vertex Buffer Objects=1 sollte abhilfe bringen (ab catalyst 5.4 steht in der changelog auch was von kotor, habs damit aber nicht mehr probiert...)

ausserdem hilft die änderung IRGENDEINER grafikoption (egal was, egal ob danach performancefressender oder -sparender...) kurzzeitig (bis zum nächsten ortswechsel/laden etc.)


http://www.planet3dnow.de/vbulletin/showthread.php?t=205281&highlight=kotor
http://www.planet3dnow.de/vbulletin/showthread.php?t=207520&highlight=kotor
http://www.planet3dnow.de/vbulletin/showthread.php?t=204718&highlight=kotor
etc...
 

GSachse

Grand Admiral Special
Mitglied seit
24.02.2002
Beiträge
2.859
Renomée
9
Standort
Halle
cr4wler schrieb:
problem is hier schon paar mal besprochen worden... Disable Vertex Buffer Objects=1 sollte abhilfe bringen (ab catalyst 5.4 steht in der changelog auch was von kotor, habs damit aber nicht mehr probiert...)

ausserdem hilft die änderung IRGENDEINER grafikoption (egal was, egal ob danach performancefressender oder -sparender...) kurzzeitig (bis zum nächsten ortswechsel/laden etc.)


http://www.planet3dnow.de/vbulletin/showthread.php?t=205281&highlight=kotor
http://www.planet3dnow.de/vbulletin/showthread.php?t=207520&highlight=kotor
http://www.planet3dnow.de/vbulletin/showthread.php?t=204718&highlight=kotor
etc...

das mit der grafikoption hilft nur bei kotor 2..
bei kotor hilft halt entweder ini umschreiben oder der 5.4er catalyst ;)


btw. geniale spielreihe :)
 

eden

Vice Admiral Special
★ Themenstarter ★
Mitglied seit
28.04.2004
Beiträge
895
Renomée
3
Woops... ich habe wirklich noch den alten 5.3 er Catalyst drauf.
Werd das gleich mal ändern. ;D
 
Oben Unten