Raid-5 aus 5x 2TB Platten Fragen

JKuehl

Grand Admiral Special
★ Themenstarter ★
Mitglied seit
22.06.2003
Beiträge
7.906
Renomée
145
Standort
Stockholm, Schweden
  • SIMAP Race
  • QMC Race
  • RCN Russia
  • Spinhenge ESL
  • Docking@Home
  • BOINC Pentathlon 2012
  • BOINC Pentathlon 2011
  • BOINC Pentathlon 2014
  • BOINC Pentathlon 2015
Doch es bringt einen Nachteil, da bei Einstellung "Raid" das System jedesmal mit einem Bluescreen aussteigt. (Die X25 lief vorher auf AHCI). Mich wundert, dass die Datenträgerverwaltung das Laufwerk trotzdem als RAID-Laufwerk erkennt, die Intel Rapid Storage aber einzelne Laufwerke anzeigt und kein Raid.

IRST: W7, 64 Bit, aktuellste Version von der Intel Website.
IAStorUi hat die Version 9.6.0.1014

hier mal ein HDTach Screen
untitled1jpck.jpg

.
EDIT :
.

und nochmal von der IRST:
Ich dachte dort müsste der RAID-Status auch angezeigt werden.. wolte mal ein Laufwerk abklemmen un zu sehen ob ein Rebuild angestoßen wird. Aber ich denke einfach, das initialisieren des Raid läuft noch....
untitled24o0y.jpg
 

yourgreatestfear

Grand Admiral Special
Mitglied seit
17.08.2003
Beiträge
5.193
Renomée
142
Standort
Dresden - Germany
Die IRST wird Dir immer alle Laufwerke die physisch vorhanden sind anzeigen, dazu ist die GUI da.
Und als ich nach dem Status fragte interessierte mich eher die Detailansicht der Laufwerke. Physische und logische Clustergrößen bzw. der Poolstatus. Die Startseite hilft niemandem.

Wie gesagt werden Deine Probleme aus dem Wechsel von RAID-Modus zu AHCI nach Erstellung des Pool entstehen. Die IRST hat nicht ohne Grund den RAID-Modi im BIOS. Anhaltspunkt nummero Uno wäre shconmal Deine IRST-Ansicht, die keinen RAIDpool grafisch darstellt, denn das sähe auch auf der Startseite vom Status schon anders aus.
 

JKuehl

Grand Admiral Special
★ Themenstarter ★
Mitglied seit
22.06.2003
Beiträge
7.906
Renomée
145
Standort
Stockholm, Schweden
  • SIMAP Race
  • QMC Race
  • RCN Russia
  • Spinhenge ESL
  • Docking@Home
  • BOINC Pentathlon 2012
  • BOINC Pentathlon 2011
  • BOINC Pentathlon 2014
  • BOINC Pentathlon 2015
Genau das dachte ich mir auch.. Ergo: ich werde mir erstmal eine Möglichkeit suchen müssen, die X25 im Raid-Modus zu betreiben ohne dass Windows sich beim Booten mit einem Blue Screen verabschiedet. Ich gehe mal davon aus, dass aus irgendeinem Grund der Raid-Treiber nicht im System ist.
 

yourgreatestfear

Grand Admiral Special
Mitglied seit
17.08.2003
Beiträge
5.193
Renomée
142
Standort
Dresden - Germany
Boote erstmal ohne erstellten RAIDpool, das geht auch über die GUI im Windows. Vielleicht gehts dann ohne Bluescreen.

zumal es dann auch eine GUI-Rückgabe zum Initialisierungsfortschritt geben sollte.
 
Zuletzt bearbeitet:

JKuehl

Grand Admiral Special
★ Themenstarter ★
Mitglied seit
22.06.2003
Beiträge
7.906
Renomée
145
Standort
Stockholm, Schweden
  • SIMAP Race
  • QMC Race
  • RCN Russia
  • Spinhenge ESL
  • Docking@Home
  • BOINC Pentathlon 2012
  • BOINC Pentathlon 2011
  • BOINC Pentathlon 2014
  • BOINC Pentathlon 2015
Ich denke das Problem ist gelöst, Laut Raidrom der ICH10R ist das Raid schlicht und ergreifend gerade am Init. Werde das mal bis morgen früh laufen lassen und schauen ob dann fertig.
.
EDIT :
.

Boote erstmal ohne erstellten RAIDpool, das geht auch über die GUI im Windows. Vielleicht gehts dann ohne Bluescreen.
Habe ich natürlich auch probiert, ging nicht. Es ging nichtmal als ich alle 4 Platten abgeklemmt hatte und nur die X25 von AHCI auf Raid gestellt habe.
 

JKuehl

Grand Admiral Special
★ Themenstarter ★
Mitglied seit
22.06.2003
Beiträge
7.906
Renomée
145
Standort
Stockholm, Schweden
  • SIMAP Race
  • QMC Race
  • RCN Russia
  • Spinhenge ESL
  • Docking@Home
  • BOINC Pentathlon 2012
  • BOINC Pentathlon 2011
  • BOINC Pentathlon 2014
  • BOINC Pentathlon 2015
Hab dann mal ein paar Registryfixes ausprobiert die den RAID-Treiber einbinden. Danach im Raid Bios die Kiste 9 Stunden stehen lassen, Status "initialize".

Als ich die Kisten dann gerade rebootet habe erkennt der IRST dann auch das Raid und zeigt 1% Fortschritt an.. jetzt mal beobachten wie lange das Raid braucht bis es fertig ist. Ich rechne mit knapp einem Tag.


.
EDIT :
.

Eben war der Init bei 2% nach einer knappen Stunde, da friert auf einmal das System fast komplett ein, ein Prozess "System" frisst eine ganze CPU auf, und dann ist eine HDD gedroppt und der IRST will einen Rebuild anstoßen.

Soweit sogut, also mal einen Neustart veranalsst und jetzt werden munter platten rausgeworfen und auf Fehlerhaft gesetzt - nichtmal mehr die Größe der Platten wird erkannt.
1opaq.jpg
22st0.jpg

.
EDIT :
.

Also mal Raid löschen - dann stürzt der IAStorUI direkt ab... oje was für eine Frickelware. Ich bin kurz davor Linux aufzusetzen und MDADM herzunehmen.
.
EDIT :
.

Was sagte Nero24 noch gleich? Pass auf mit Seagate:
tja 12 Stunden nach Einbau der Platten wird eine von 4 nicht mehr erkannt, und eine weitere ist defekt:
untitled265qa.jpg

.
EDIT :
.

ps: allesamt mit firmware cc34
ich versuche mal das update auf cc35

sonst gehen die platten zurück die F4 gibts seit heute auch für ebenfalls 85€ das stück
 

trick

Vice Admiral Special
Mitglied seit
30.03.2007
Beiträge
923
Renomée
10
  • Spinhenge ESL
unter linux kannst du, sofern deine platten dies unterstützen, per smart den timer für die fehlerbehandlung verändern ( vgl tler bei wd re platten). dadurch reduzierst du das risiko, dass das array eine intakte platte droppt. prinzipiell geht das auch untr windows, allerdings verhindert das array dn zugriff auf die einzelnen platten, daher kann mans unter windows nicht ohne weiteres nutzen.
 

JKuehl

Grand Admiral Special
★ Themenstarter ★
Mitglied seit
22.06.2003
Beiträge
7.906
Renomée
145
Standort
Stockholm, Schweden
  • SIMAP Race
  • QMC Race
  • RCN Russia
  • Spinhenge ESL
  • Docking@Home
  • BOINC Pentathlon 2012
  • BOINC Pentathlon 2011
  • BOINC Pentathlon 2014
  • BOINC Pentathlon 2015
Tja laut Seagate gibts kein Firmware Update für die Teile von CC34 auf CC35 - damit gehen die Teile nichtmal einen Tag nach Kauf direkt zurück an den Händler....
.
EDIT :
.

Händler ist informiert, mal schauen wann ich Rückmeldung erhalte - werde dann direkt auf die Samsung F4 HD204UI umsteigen.
 

yourgreatestfear

Grand Admiral Special
Mitglied seit
17.08.2003
Beiträge
5.193
Renomée
142
Standort
Dresden - Germany
1. IAStorUI als Frickelware zu bezeichnen ist deftig, wenn man mit Bluescreens, aussteigenden Platten, "Registryfixes" etc. zu kämpfen hat.

2. Ausgehend von Deinen Screens könnten noch immer sowohl der nachträgliche Umstieg in der Schnittstellenkonfiguration, falsches Alignment bzw. uneinheitliche Clustergrößen und/oder Deine 'Fixes' Ursache sein.

3. Selbst wenn ein paar Sektoren fehlerhaft/schwebend sind dürfte eine Platte nicht aussteigen, was eher auf andere bzw. weitere Probleme hindeutet, welche nicht zwingend beim Laufwerk zu suchen sind.

4. "Hab dann mal ein paar Registryfixes ausprobiert die den RAID-Treiber einbinden. " Klingt nicht sehr vertrauenserweckend. Was bedeutet das? Als 'RAID' initialisiert, dann auf AHCI umgestellt und dann per Registrygemogel andere Treiber erzwungen?

5. Für 1 aus 4 defekt stehen die Chancen nicht schlecht, bei 2 aus 4 würde ich stutzig werden, ob wirklich die Platten das Problem sind.

Empfehlung: Laufwerke einzeln mit LiveCD bei einheitlicher Konfiguration initialisieren und testen, ohne die SSD und irgendwelcher Fixes.
Oder aber darauf hoffen, dass wirklich nur die Laufwerke schuld sind und im Worst Case mit allen weiteren Laufwerkstypen die gleichen Probleme ans Land ziehen.
 

JKuehl

Grand Admiral Special
★ Themenstarter ★
Mitglied seit
22.06.2003
Beiträge
7.906
Renomée
145
Standort
Stockholm, Schweden
  • SIMAP Race
  • QMC Race
  • RCN Russia
  • Spinhenge ESL
  • Docking@Home
  • BOINC Pentathlon 2012
  • BOINC Pentathlon 2011
  • BOINC Pentathlon 2014
  • BOINC Pentathlon 2015
1. IAStorUI als Frickelware zu bezeichnen ist deftig, wenn man mit Bluescreens, aussteigenden Platten, "Registryfixes" etc. zu kämpfen hat.

2. Ausgehend von Deinen Screens könnten noch immer sowohl der nachträgliche Umstieg in der Schnittstellenkonfiguration, falsches Alignment bzw. uneinheitliche Clustergrößen und/oder Deine 'Fixes' Ursache sein.

3. Selbst wenn ein paar Sektoren fehlerhaft/schwebend sind dürfte eine Platte nicht aussteigen, was eher auf andere bzw. weitere Probleme hindeutet, welche nicht zwingend beim Laufwerk zu suchen sind.

4. "Hab dann mal ein paar Registryfixes ausprobiert die den RAID-Treiber einbinden. " Klingt nicht sehr vertrauenserweckend. Was bedeutet das? Als 'RAID' initialisiert, dann auf AHCI umgestellt und dann per Registrygemogel andere Treiber erzwungen?

5. Für 1 aus 4 defekt stehen die Chancen nicht schlecht, bei 2 aus 4 würde ich stutzig werden, ob wirklich die Platten das Problem sind.

Empfehlung: Laufwerke einzeln mit LiveCD bei einheitlicher Konfiguration initialisieren und testen, ohne die SSD und irgendwelcher Fixes.
Oder aber darauf hoffen, dass wirklich nur die Laufwerke schuld sind und im Worst Case mit allen weiteren Laufwerkstypen die gleichen Probleme ans Land ziehen.

Wenn mein Ton jetzt vielelicht etwas scharf klingt, möchte ich dich im vorhinein bitten das nicht persönlich zu nehmen, ich stehe nur gerade ziemlich unter Stress.

1. Sorry aber bei solchen RAID-Geschichten muss das Tool 100% laufen - und nicht so viele Fehler werfen. Bei reinen Softwarelösungen wie MDADM gehts doch auch.

2. Eine Platte wird garnicht mehr erkannt, was auch bei der 2TB Seagate ein bekanntes Problem ist - angeblich gibts da auch ein Update auf V35 (die HDDs haben V34), was aber das Seagate Tool nicht einspielen will. Wenn die Teile schon nach nichtmal einem Tag solche Probleme haben: zack zurück an den Händler und anderer Hersteller.

3. Doch, wenn die TLER zu hoch ist und der Controller die Platte droppt. (Es sind Desktop-HDDS und keine Raid-Editions).

4. Das Problem habe ich doch schon geschildert und das ist auch Web-weit bekannt: auch unter WIndows 7 muss der Raidtreiber beim Booten vorhanden sein. Wenn aber vorher auf AHCI gefahren wurde (die X25-M) dann gibts Bluescreens. DIe Registryfixes binden dann beide Treiber ein - den AHCI um das System nochmal runterzufahren, den RAID um dann nach Umstellung im Bios auch die X25-M mit dem korrekten Treiber ansprechen zu können. Die vorhandene Windowsinstallation ist über 18 Monate alt, die installiere ich sicher nicht neu nur um den Treiber einzubinden.

5. Eben.. Eine Platte aus vieren hat die Wahrscheinlichkeit von n^4 einer Einzelausfallsmöglichkeit. Darum habe ich bewusst bei RAID-5 auf 4 Platten gesetzt, obwohl ich eigentlich den Platz von 5 gebrauchen könnte. Das zieht aber nach sich, dass ich dann den oben genannten Fileserver aufsetzen möchte, das dann aber gleich mit RAID-6 und 6 Platten.

Fazit: Das Raid sollnur eine Übergangslösung für die nächsten paar Monate werden, um eine höhere Datensicherheit als aktuell zu erreichen. Zweitens habe ich dafür aber auch nicht 50 Stunden Zeit, mich mit dem Kram herumzuschlagen. Auf der Arbeit geht derzeit zügig her, da bleibt wenig Zeit für solche Sachen.

Mir ist auch bewusst, dass schwebenede Sektoren nicht nur durch physikalische Defekte entstehen sondern auch oft Sektoren als schwebend markiert werden wenn bei Schreibzugriff z.B. der Strom ausfällt. Dennoch meldet die Software die HDD als ausgefallen. Für die Software machts also garkeinen Unterschied: diese HDD ist ausgefallen, die zweite ist komplett gedroppt - das Raid ist hinüber.

Am Ende zählt für mich nur das Ergebnis, und das ist in dieser Kombination vernichtend. Ich warte jetzt auf die bestellten Samsung F4 und hoffe dass diese sich besser schlagen.
.
EDIT :
.

So ich hab jetzt nochmal alles überprüft, alle SATA-Kabel vorsichtshalber gegen brandneue getauscht, die Software nochmal neu installiert, alle Platten abgezogen und erst unter Windows per HOT-Plug angeschlossen.

Und siehe da: ich kann auch unter der Software jetzt ein RAID-5 erstellen. Dieses initialisert gerade. Mal schauen was nun weiter passiert....
 
Zuletzt bearbeitet:

yourgreatestfear

Grand Admiral Special
Mitglied seit
17.08.2003
Beiträge
5.193
Renomée
142
Standort
Dresden - Germany
1. Sorry aber bei solchen RAID-Geschichten muss das Tool 100% laufen - und nicht so viele Fehler werfen. Bei reinen Softwarelösungen wie MDADM gehts doch auch.

Aja, md(adm) hat ja auch null Probleme :]. Wie schön das doch wäre, aber die Realität sieht leider anders aus und nicht wenige haben so ihre liebe Not mit Bugs a la soft lockup, Bootunterbrechungen etc.

Bezüglich Deiner kommenden Erfahrungen bin ich ja mal gespannt. Weitere Kommentare oder Vorschläge spar ich mir lieber, hab so eine Ahnung wo das Problem sitzt, wenn man mal liest wie schnell und fundiert Fehler ausgemacht und Urteile gefällt werden.
 

JKuehl

Grand Admiral Special
★ Themenstarter ★
Mitglied seit
22.06.2003
Beiträge
7.906
Renomée
145
Standort
Stockholm, Schweden
  • SIMAP Race
  • QMC Race
  • RCN Russia
  • Spinhenge ESL
  • Docking@Home
  • BOINC Pentathlon 2012
  • BOINC Pentathlon 2011
  • BOINC Pentathlon 2014
  • BOINC Pentathlon 2015
Klar kannst du dir deine Meinung bilden, dass ich die Fehlerquelle bin - ist auch ok aber das Urteil ist dann ebenso schnell gefällt, wie ich hier meine Erfahrungen und Fortschritte poste... Ich könnte jetzt auch 3 Wochen im Verborgenen frickeln und mich erst dann mitteilen. So bin ich aber nicht.
 
G

Gast29012019_2

Guest
Da du ja ein Gigabyte Board hast, wäre das neuste Bios-Update Plicht, falls das Board auf Virtual Dual Bios setzt, bzw. Feature abschalten, da es sobst Probleme mit 2TB Festplatten gibt, das als Allgemeine Info.
 

JKuehl

Grand Admiral Special
★ Themenstarter ★
Mitglied seit
22.06.2003
Beiträge
7.906
Renomée
145
Standort
Stockholm, Schweden
  • SIMAP Race
  • QMC Race
  • RCN Russia
  • Spinhenge ESL
  • Docking@Home
  • BOINC Pentathlon 2012
  • BOINC Pentathlon 2011
  • BOINC Pentathlon 2014
  • BOINC Pentathlon 2015
neuestes Bios in Version F9d ist natürlich drauf.

Aber das hier ist wirklich interessant - das werde ich mir heute mal noch zu Gemüte führen:
http://ht4u.net/forum/index.php?topic=48056.0

Falls du allerdings das Feature meinst, das Bios auf HDD zu sichern - von dem Quatsch habe ich noch nie was gehalten und das ist natürlich abgeschaltet ;-)
 
G

Gast29012019_2

Guest
Und das war ja nur die Spitze des Eisberges, angefangen hat alles schon 2006/07 mit vielen Gigabyte Boards die aufgrund eines fehlerhaften Bios keine 1TB Platten nutzen konnte, das verbaute Board wird es auch nie können, da es aufgrund seines Alters keine Bios-Pflege erhalten wird. Und das Board wurde sowohl im Endk. als auch OEM Bereich verbaut, so ist der verbaute Nvidia N-Force 2 Controller nutzlos.
 
Zuletzt bearbeitet:

JKuehl

Grand Admiral Special
★ Themenstarter ★
Mitglied seit
22.06.2003
Beiträge
7.906
Renomée
145
Standort
Stockholm, Schweden
  • SIMAP Race
  • QMC Race
  • RCN Russia
  • Spinhenge ESL
  • Docking@Home
  • BOINC Pentathlon 2012
  • BOINC Pentathlon 2011
  • BOINC Pentathlon 2014
  • BOINC Pentathlon 2015
so muss dat aussehen - raidstatus "Normal"
snap012ahwg.jpg
 
G

Gast29012019_2

Guest
Messe am besten mit HDtune 4.x -> Einstellungen -> Acurate und max Blockgröße, jeweils schreiben und lesen. Ist das jetzt der Verbund mit den Samsung Platten ?
 

JKuehl

Grand Admiral Special
★ Themenstarter ★
Mitglied seit
22.06.2003
Beiträge
7.906
Renomée
145
Standort
Stockholm, Schweden
  • SIMAP Race
  • QMC Race
  • RCN Russia
  • Spinhenge ESL
  • Docking@Home
  • BOINC Pentathlon 2012
  • BOINC Pentathlon 2011
  • BOINC Pentathlon 2014
  • BOINC Pentathlon 2015
Da hat sich noch nichts weiter getan.
 

bbott

Grand Admiral Special
Mitglied seit
11.11.2001
Beiträge
4.370
Renomée
60
Hi,

hat jemand Erfahrung mit dem Bobcat und Software Raid? Ich planen mit dem ASUS E35M1-M (PRO) einen File Server Aufzusetzen, aber bin mir nicht sicher ob die Performance reicht für Raid 5 (+ VM's)?

Ich bin mir noch nicht sicher welche Aufgaben der noch Server alles über nehmen soll.

Ein NB Platte fürs BS sollte dafür sogen dass die 3,5 HDD die meiste Zeit schlafen können, oder? Ansonsten wird der Server nur nach Bedarf laufen. Als BS hatte ich Windows Server 2008 R2 (kostenlos dank MSDNAA) oder evt. ein Linux (müsste mich da noch Schlau machen)
Für VM's wäre da wahrscheinlich nicht mehr allzu viel Luft, oder?


Gibt es NT's die Ihr empfehlen könnt? Die für 5-6 HDDs (4x bis 5x 3,5" + 1x 2,5") reichen. Würde gerne die guten Idle Werte des E350 nutzen ;-)

@ JKuehl
Ist der Bench von dem Software Raid? Mit was für einem Prozessor?
 

JKuehl

Grand Admiral Special
★ Themenstarter ★
Mitglied seit
22.06.2003
Beiträge
7.906
Renomée
145
Standort
Stockholm, Schweden
  • SIMAP Race
  • QMC Race
  • RCN Russia
  • Spinhenge ESL
  • Docking@Home
  • BOINC Pentathlon 2012
  • BOINC Pentathlon 2011
  • BOINC Pentathlon 2014
  • BOINC Pentathlon 2015
Steht doch da ;-) Intel Hardware Raid auf ICH-10.
 

bbott

Grand Admiral Special
Mitglied seit
11.11.2001
Beiträge
4.370
Renomée
60

Alith Anar

Lieutnant
Mitglied seit
14.03.2007
Beiträge
93
Renomée
0
Standort
Berlin
Hallo,

Ich lese hier gerade von RAID grössen über 2 TB.
Habt Ihr da spezielle Boards? Ich denk MBR kann nur 2 TB Verwalten, zumindest zickte mein K10N78 Rum, als ich ihm 4 x 750 GB HDDs zu nem RAID 5 zusammengeschaltet habe. die Letzten 100 GB liessen sich definitiv nicht ansprechen...
 

yourgreatestfear

Grand Admiral Special
Mitglied seit
17.08.2003
Beiträge
5.193
Renomée
142
Standort
Dresden - Germany
Raidcontroller stellen nur vituelle Datenträger zur Verfügung. Wie Deinerein dann Partitioniert, ob überhaupt MBR klassisch verwendet wird und wie demnach die maximale Partitionsgröße ist steht auf einem ganz anderen Blatt.
 
Zuletzt bearbeitet:
Oben Unten