Massive WLAN Probleme Win10/verschiedene NICs

Kirschi

Admiral Special
★ Themenstarter ★
Mitglied seit
23.07.2002
Beiträge
1.812
Renomée
3
Standort
Franken
Hallo Freunde,

seit einigen Wochen habe ich massive Probleme mit meinem Laptop eine zuverlässige WLAN Verbindung aufzubauen. Ich verwende Windows 10 und hatte vor einigen Monaten den Windows Update Service abgeschaltet. Der Laptop lag dann einige Zeit (vielleicht 3 bis 4 Wochen) unbenutzt herum. Nach Einschalten konnte ich mich erst mal gar nicht verbinden. Daraufhin habe ich den Windows Update Dienst wieder angeschaltet, die NIC deaktiviert/aktiviert, den Treiber re-installiert usw. Dann hat die Verbindung auch funktioniert. Leider funktioniert seitdem die WLAN Verbindung nur sehr unzuverlässig, die Performance der Verbindung (auch ins Internet ist sehr schlecht).

Beim Kopieren von Dateien auf meine NAS, beginnt der Kopiervorgang ganz normal für die ersten Sekunden und bricht dann ab. In diesem Zustand ist auch kein Ping zum Router möglich. Nach einigen Minuten wird die Verbindung wieder hergestellt. Ich habe daraufhin auch den internen WLAN Adapter abgeschaltet und einen externen USB Adapter angeschlossen, das brachte jedoch auch keine Besserung.

Im Eventlog sehe ich die folgenden Einträge:

Code:
Das WLAN-Erweiterungsmodul konnte nicht gestartet werden.

Modulpfad: C:\WINDOWS\system32\athExt.dll
Fehlercode: 126
Code:
Bei der automatischen WLAN-Konfiguration wurde eine eingeschränkte Konnektivität erkannt, "Reset/Recover.adapter" wird ausgeführt.

 Code: 8 0x0 0x0

Per Kabel funktioniert mein Netz einwandfrei. Ich nutze eine Fritzbox 7390 und einen TP-Link Router als Repeater.

Any help appreciated.

Danke,
Kirschi
 

Nero24

Administrator
Teammitglied
Mitglied seit
01.07.2000
Beiträge
23.011
Renomée
8.831
  • BOINC Pentathlon 2019
  • BOINC Pentathlon 2020
  • BOINC Pentathlon 2018
Hi,

probier mal bitte zuerst nur mit der Fritzbox, ohne Repeater, um eine Fehlkonfiguration an dieser Stelle auszuschließen.

Wenn es nur mit der Fritzbox das gleiche Problem ist, deaktiviere mal bitte im Geräte-Manager beim WLAN-Treiber unter Energieverwaltung den Haken, dass der Computer das Gerät zum Energiesparen abschalten darf. Bei einem USB-WLAN-Stick deaktiviere unter Systemsteuerung / Energie-Optionen in den erweiterten Einstellungen Deines genutzten Energie-Profils zusätzlich die Optionen USB-Stromsparen.

Dann mal probieren.
 

Kirschi

Admiral Special
★ Themenstarter ★
Mitglied seit
23.07.2002
Beiträge
1.812
Renomée
3
Standort
Franken
Hi,

probier mal bitte zuerst nur mit der Fritzbox, ohne Repeater, um eine Fehlkonfiguration an dieser Stelle auszuschließen.

Wenn es nur mit der Fritzbox das gleiche Problem ist, deaktiviere mal bitte im Geräte-Manager beim WLAN-Treiber unter Energieverwaltung den Haken, dass der Computer das Gerät zum Energiesparen abschalten darf. Bei einem USB-WLAN-Stick deaktiviere unter Systemsteuerung / Energie-Optionen in den erweiterten Einstellungen Deines genutzten Energie-Profils zusätzlich die Optionen USB-Stromsparen.

Dann mal probieren.

Es liegt an dem TP Link Router.....vielen Dank erstmal für den Hinweis. Hat Jemand ne Ahnung ob das eine Einstellungssache ist?
 

Nero24

Administrator
Teammitglied
Mitglied seit
01.07.2000
Beiträge
23.011
Renomée
8.831
  • BOINC Pentathlon 2019
  • BOINC Pentathlon 2020
  • BOINC Pentathlon 2018
Wie ist denn der TP-Link im Einsatz gewesen? Tatsächlich als Repeater wie Du geschrieben hast, oder als zweiter Access-Point, per LAN-Kabel mit dem Netzwerk verbunden?
 

Kirschi

Admiral Special
★ Themenstarter ★
Mitglied seit
23.07.2002
Beiträge
1.812
Renomée
3
Standort
Franken
Nein als zweiter Access Point. Ich hatte früher zwei WLANs mit zwei verschiedenen SSIDs. Ich habe dann auf dem TP Link Router einen HW Reset gemacht, die neueste FW installiert und ihn dann als zweiten AP konfiguriert.
 

Nero24

Administrator
Teammitglied
Mitglied seit
01.07.2000
Beiträge
23.011
Renomée
8.831
  • BOINC Pentathlon 2019
  • BOINC Pentathlon 2020
  • BOINC Pentathlon 2018
Ok, wenn Du zwei Access-Points für dieselbe SSID nutzen willst, musst Du ein paar Sachen beachten.

1. Es darf nur einen DHCP-Server im Netzwerk geben. Lass den Gateway als DHCP arbeiten, in diesem Fall also die Fritzbox. Beim TP-Link schaltest Du DHCP aus.

2. Achte darauf, dass der TP-Link via LAN-Port mit dem Netzwerk verbunden ist, nicht via WAN/Internet!

3. Gib Fritzbox und TP-Link unterschiedliche IPs im gleichen Subnet, also z.B. 192.168.178.1 für die Fritzbox und 192.168.178.2 für den TP-Link.

4. Nutze sowohl bei Fritzbox, als auch beim TP-Link die gleiche SSID, Verschlüsselungsmethode (WPA2 AES) und den gleichen WLAN-Key.

5. Stelle beide Geräte auf 20 MHz Bandbreite bzw. schalte die Option 300 Mbit/s aus, da es sonst schwierig wird, überschneidungsfreie Kanäle zu finden.

6. Stelle die Fritzbox auf WLAN-Kanal 1 und den TP-Link auf WLAN-Kanal 9, also möglichst weit voneinander entfernt. Grundsätzlich sollten die Kanäle bei 2,4 GHz n-WLAN und 20 MHz Bandbreite mindestens 4 Kanäle weit auseinander sein. Im Idealfall wären also die Kanäle 1, 5, 9 und 13 überschneidungsfrei nutzbar. 13 ist nur nicht von allen Endgeräten nutzbar, daher lieber vermeiden.

7. Falls die Fritzbox und/oder TP-Link auch 5 GHz WLAN unterstützen, schalt es ab. Es ist schwierig, mit mehreren APs eine nahtlose Abdeckung bei simultaner Nutzung von 2,4 GHz und 5 GHz hinzukriegen. Da kanns passieren, dass sich ein Laptop z.B. auf dem 2,4 GHz Band mit dem TP-Link verbindet und auf dem 5 GHz Band mit der Fritzbox. Und dann geht gar nichts mehr, weil die Pakete nicht mehr wissen wohin. Also nutze nur das 2,4 GHz Band, weil das die größere Reichweite hat.

Wenn Du das genau beachtest, sollte es problemlos funktionieren. Hab ein ganzes Hotel auf diese Weise verwlant (nicht nur mit 2 APs) und man kann sich mit dem Laptop frei im Haus bewegen ohne irgendwo offline zu sein :D
 
Zuletzt bearbeitet:

ghostadmin

Grand Admiral Special
Mitglied seit
11.11.2001
Beiträge
24.595
Renomée
126
Standort
Dahoam Studios
Wenn Du das genau beachtest, sollte es problemlos funktionieren. Hab ein ganzes Hotel auf diese Weise verwlant (nicht nur mit 2 APs) und man kann sich mit dem Laptop frei im Haus bewegen ohne irgendwo offline zu sein

welche AP hast du da verwendet? Hattest du schon mal das Problem das man nur mit WLAN nicht mehr zurande kommt? Weil AVM gibt ja Kaskadierung nicht offiziell frei, ausserdem leidet die Bandbreite.
In welchem Gebiet bist du eigentlich tätig?
 
Zuletzt bearbeitet:

Kirschi

Admiral Special
★ Themenstarter ★
Mitglied seit
23.07.2002
Beiträge
1.812
Renomée
3
Standort
Franken
Ok, wenn Du zwei Access-Points für dieselbe SSID nutzen willst, musst Du ein paar Sachen beachten.

1. Es darf nur einen DHCP-Server im Netzwerk geben. Lass den Gateway als DHCP arbeiten, in diesem Fall also die Fritzbox. Beim TP-Link schaltest Du DHCP aus.

2. Achte darauf, dass der TP-Link via LAN-Port mit dem Netzwerk verbunden ist, nicht via WAN/Internet!

3. Gib Fritzbox und TP-Link unterschiedliche IPs im gleichen Subnet, also z.B. 192.168.178.1 für die Fritzbox und 192.168.178.2 für den TP-Link.

4. Nutze sowohl bei Fritzbox, als auch beim TP-Link die gleiche SSID, Verschlüsselungsmethode (WPA2 AES) und den gleichen WLAN-Key.

5. Stelle beide Geräte auf 20 MHz Bandbreite bzw. schalte die Option 300 Mbit/s aus, da es sonst schwierig wird, überschneidungsfreie Kanäle zu finden.

6. Stelle die Fritzbox auf WLAN-Kanal 1 und den TP-Link auf WLAN-Kanal 9, also möglichst weit voneinander entfernt. Grundsätzlich sollten die Kanäle bei 2,4 GHz n-WLAN und 20 MHz Bandbreite mindestens 4 Kanäle weit auseinander sein. Im Idealfall wären also die Kanäle 1, 5, 9 und 13 überschneidungsfrei nutzbar. 13 ist nur nicht von allen Endgeräten nutzbar, daher lieber vermeiden.

7. Falls die Fritzbox und/oder TP-Link auch 5 GHz WLAN unterstützen, schalt es ab. Es ist schwierig, mit mehreren APs eine nahtlose Abdeckung bei simultaner Nutzung von 2,4 GHz und 5 GHz hinzukriegen. Da kanns passieren, dass sich ein Laptop z.B. auf dem 2,4 GHz Band mit dem TP-Link verbindet und auf dem 5 GHz Band mit der Fritzbox. Und dann geht gar nichts mehr, weil die Pakete nicht mehr wissen wohin. Also nutze nur das 2,4 GHz Band, weil das die größere Reichweite hat.

Wenn Du das genau beachtest, sollte es problemlos funktionieren. Hab ein ganzes Hotel auf diese Weise verwlant (nicht nur mit 2 APs) und man kann sich mit dem Laptop frei im Haus bewegen ohne irgendwo offline zu sein :D

Hey Nero, also vielen Dank für die zahlreichen Tipps. Punkt 6 und 7 waren es, alle anderen hatte ich bereits entsprechend vorher konfiguriert!
 
Oben Unten