Zweite IP Adresse

ghostadmin

Grand Admiral Special
★ Themenstarter ★
Mitglied seit
11.11.2001
Beiträge
24.595
Renomée
126
Standort
Dahoam Studios
Ich steh grad etwas auf dem Schlauch, ich habe mehrere virtuelle Maschinen mit Linux auf einem Host die ohne Probleme laufen aber eine hat etwas ungewöhnliches:

ip route
default via 192.168.5.1 dev eth0 src 192.168.5.155 metric 202
192.168.5.0/24 dev eth0 proto kernel scope link src 192.168.5.155 metric 202

Die ip .155 ist vermutlich vom DHCP Server vergeben aber wo kommt diese her? Ich kann diese anpingen sobald die Maschine startet.

route:
Kernel-IP-Routentabelle
Ziel Router Genmask Flags Metric Ref Use Iface
default router.intern.l 0.0.0.0 UG 202 0 0 eth0
192.168.5.0 0.0.0.0 255.255.255.0 U 202 0 0 eth0


ifconfig:
eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
inet 192.168.5.13 netmask 255.255.255.0 broadcast 192.168.5.255
inet6 2003:c7:870a:1500:5054:ff:fe6a:8831 prefixlen 64 scopeid 0x0<global>


/etc/network/interfaces:
auto lo
iface lo inet loopback

allow-hotplug eth0
iface eth0 inet static
address 192.168.5.13
netmask 255.255.255.0
gateway 192.168.5.1
broadcast 192.168.5.255

Auf dem Linux läuft nur Apache, FTP, Mysql und Quassel
 
Zuletzt bearbeitet:

Riddler82

Leitung Moderation
Teammitglied
Mitglied seit
11.11.2001
Beiträge
9.339
Renomée
202
Standort
Bayern, am Rande des Wahnsinns
  • SIMAP Race
  • QMC Race
  • Spinhenge ESL
  • BOINC Pentathlon 2012
  • BOINC Pentathlon 2014
Von welcher Distribution reden wir da? Je nach Distri wird das teils deutlich unterschiedlich gehandhabt, wo und und wie die Netzwerkkonfigs liegen.

Unter Ubuntu können z.B. unter /etc/NetworkManager/ welche liegen (wenn per NetworkManager verwaltet, bei mir tauchen auf meiner Workstation in der Firma hier unter /etc/NetworkManager/system-connections/ diverse VPNs auf), während unter RHEL/CentOS7 unter /etc/sysconfig/network-scripts/ die zusätzlichen IPs definiert werden können. /etc/sysconfig/network-scripts/ifcfg-eth0 und unter ifcfg-eth0:1 für das selbe Interface eine zusätzliche Konfiguration liegt.
 
Zuletzt bearbeitet:

Riddler82

Leitung Moderation
Teammitglied
Mitglied seit
11.11.2001
Beiträge
9.339
Renomée
202
Standort
Bayern, am Rande des Wahnsinns
  • SIMAP Race
  • QMC Race
  • Spinhenge ESL
  • BOINC Pentathlon 2012
  • BOINC Pentathlon 2014
Was sagt "ip a" ? ifconfig liefert inzwischen nicht mehr zuverlässig alle infos, hatten wir schon mehrfach.

netstat -rnv könnte auch noch was nützliches ausgeben.

Welches Debian ist es genau und wurde es aktualisiert oder ist es "frisch" ?

Ansonstem kannst ja probieren mit nmap zu scannen was auf der IP lauscht, vielleicht hilft das weiter? edit: Oder "ss -tapen" damit sieht man auch recht genau was aus welcher IP los ist.
 
Zuletzt bearbeitet:

ghostadmin

Grand Admiral Special
★ Themenstarter ★
Mitglied seit
11.11.2001
Beiträge
24.595
Renomée
126
Standort
Dahoam Studios
da kommt die Adresse auch (secondary), ist schon zig mal aktualisiert worden das Debian (Stretch)

wenn ich dhcpcd ausschalte dann ist es weg

in den anderen (neueren) Maschinen hab ich ens3 stehen, nicht eth0 wie früher. Vielleicht liegts daran.
 
Zuletzt bearbeitet:

Riddler82

Leitung Moderation
Teammitglied
Mitglied seit
11.11.2001
Beiträge
9.339
Renomée
202
Standort
Bayern, am Rande des Wahnsinns
  • SIMAP Race
  • QMC Race
  • Spinhenge ESL
  • BOINC Pentathlon 2012
  • BOINC Pentathlon 2014
Wenn ich da nochmal so drüberschaue dürfte das "Problem" eher normales Verhalten sein.

Du definierst ja eine statische IP und hast durch den Eintrag "allow-hotplug eth0" für das Interface eine DHCP-Adresse angefordert/erlaubt, die taucht dann nämlich als secondary auf.
Nimm das allow-hotplug mal für das interface raus.

Das ethX-Namenschema wird übrigens eigentlich auch schon nicht mehr empfohlen und es kann sein, dass es dir mit dem Update auf Debian10 um die Ohren fliegt.

beispiel für eine cat /etc/network/interfaces
Code:
auto lo
iface lo inet loopback

auto eno1
iface eno1 inet dhcp

auto eno1:1
iface eno1:1 inet static
address 192.168.254.250
netmask 255.255.255.0

auto eno1:2
iface eno1:2 inet static
address 10.0.0.2
netmask 255.255.0.0
gateway 10.0.0.1

Wäre ein beispiel für die aktuelle konvention, eno1 bezieht per dhcp, eno1:1 hat eine statische IP und nutzt das selbe Gateway wie eno1, während eno1:2 eine anderes netz und gateway benutzt. mit allow-hotplug kann es halt sein, dass du dann noch eine dhcp IP bekommst. Wie gesagt, KANN, sollte aber eignetlich nicht. Sonst fällt mir nämlich auch grad nix mehr ein.

noch ein edit:
"ls -alh /sys/class/net/" kannst dir die interfaces anzeigen lassen ist auch interessant.

Existiert bei dir noch /etc/udev/rules.d/70-local-persistent-net.rules ?
 
Zuletzt bearbeitet:

ghostadmin

Grand Admiral Special
★ Themenstarter ★
Mitglied seit
11.11.2001
Beiträge
24.595
Renomée
126
Standort
Dahoam Studios
Du definierst ja eine statische IP und hast durch den Eintrag "allow-hotplug eth0" für das Interface eine DHCP-Adresse angefordert/erlaubt, die taucht dann nämlich als secondary auf.
Nimm das allow-hotplug mal für das interface raus.

ich hatte vorher statt dessen auto, kommt aufs gleiche und hotplug hat nichts mit dhcp zu tun

noch ein edit:
"ls -alh /sys/class/net/" kannst dir die interfaces anzeigen lassen ist auch interessant.

nur ein Interface

Existiert bei dir noch /etc/udev/rules.d/70-local-persistent-net.rules ?

nope, auch schon geschaut

habe jetzt auf ens3 umgestellt, man muss bei einer VM zusätzlich noch /etc/systemd/network/50-virtio-kernel-names.link löschen, dass ist nicht dokumentiert
 

Riddler82

Leitung Moderation
Teammitglied
Mitglied seit
11.11.2001
Beiträge
9.339
Renomée
202
Standort
Bayern, am Rande des Wahnsinns
  • SIMAP Race
  • QMC Race
  • Spinhenge ESL
  • BOINC Pentathlon 2012
  • BOINC Pentathlon 2014
ich hatte vorher statt dessen auto, kommt aufs gleiche und hotplug hat nichts mit dhcp zu tun
Eigentlich hats nichts mit dhcp zu tun, ja. Und man kann es wie auto nutzen. Aber man kriegt trotzdem manchmal lustige Effekte.


habe jetzt auf ens3 umgestellt, man muss bei einer VM zusätzlich noch /etc/systemd/network/50-virtio-kernel-names.link löschen, dass ist nicht dokumentiert

Ganz toll. Hauptsache es klappt jetzt. *great*
 

ghostadmin

Grand Admiral Special
★ Themenstarter ★
Mitglied seit
11.11.2001
Beiträge
24.595
Renomée
126
Standort
Dahoam Studios
Ne jetzt hab ich nur ens3 statt eth0, die zusätzliche IP kommt immer noch. Sofern ich eben nicht dhcpcd deaktiviere.

Edit: Lösung ist in dhcpcd.conf den Parameter ipv6only reinsetzen, anscheinend macht der automatisch auch noch ipv4 obwohl in interfaces gar nicht definiert. Bei ipv6 brauche ich dhcp weil Prefix dynamisch vom Router kommt.
 
Zuletzt bearbeitet:
Oben Unten