Mainboard defekt - BIOS reparieren?

8256

Cadet
★ Themenstarter ★
Mitglied seit
21.04.2020
Beiträge
18
Renomée
5
Hallo zusammen,

das Mainboard meines Nachbarn ist kaputt gegangen und er hat mein altes Bundle mit AMD A4-4000 als Ersatz verbaut bekommen (macht nur Online-Banking damit, sonst wirklich nichts).

Auf jeden Fall habe ich jetzt sein altes Mainboard (ASRock B75M-DGS) mit CPU hier schon eine Weile rumliegen. Nach dem einschalten läuft nur noch der CPU Lüfter an, geht aus, wieder an, wieder aus, ... die CPU habe ich getestet und diese funktioniert einwandfrei, auch eine andere CPU habe ich mit dem Mainboard erfolglos getestet.
Der optische Zustand ist perfekt, keine geblähten Kondensatoren o.ä., noch nicht einmal Staub ist vorhanden. Der Rechner hat eine Laufzeit im niedrigen, zweistelligen Stundenbereich und wurde immer vom Strom getrennt.
Die BIOS Batterie war tatsächlich schon müde, habe ich aber bereits getauscht und den Jumper gesetzt, um die Einstellungen zurückzusetzen. Das Problem bleibt aber bestehen. Ich vermute, dass eventuell das BIOS einfach nur neu geflashed werden müsste.

Es gibt ja bereits EEPROM Flasher für kleines Geld (z.B. https://www.amazon.de/Diamoen-CH341A-USB-Programmierer-Programmer-Routing-LCD-Flash/dp/B08F26JZPW) und meine Idee war es, so ein Teil günstig zu kaufen und das Board bzw. das BIOS zu reparieren.

Hat damit schon mal jemand BIOS images mit so einem günstigen USB Teil geschrieben? War das erfolgreich? Worauf muss man achten? Welche Software wird benötigt?
Ich habe zwar schon gegoogelt, aber nichts gefunden, wo das jemand im Detail beschreibt, wie das funktioniert. Hauptsächlich findet man Anbieter, die das für einen machen, aber schon EEPROM hinschicken, plus die zusätzliche Kosten übersteigen den Preis eines anderen gebrauchten Bundles bei eBay, welches garantiert funktioniert.

Natürlich fragt Ihr euch, warum ich das machen möchte, wenn man doch ein funktionierendes Bundle bei eBay für um die 25 EUR bekommt. Zum einen geht es darum meinen Horizont zu erweitern und auf der anderen Seite freue ich mich natürlich wenn es wieder funktioniert. :-)
Wenn die Lösung natürlich monatelange Recherche benötigt, um sich Spezialwissen anzueignen, welches man nie wieder benötigt, oder man doch teureres Equipment benötigt, werde ich den Versuch natürlich einstellen.
 

MagicEye04

Grand Admiral Special
Mitglied seit
20.03.2006
Beiträge
19.313
Renomée
438
Standort
oops,wrong.planet..
  • BOINC Pentathlon 2011
  • BOINC Pentathlon 2012
  • BOINC Pentathlon 2013
  • BOINC Pentathlon 2014
  • BOINC Pentathlon 2015
  • BOINC Pentathlon 2016
  • BOINC Pentathlon 2017
  • BOINC Pentathlon 2018
  • BOINC Pentathlon 2019
  • SETI@Home Wow!-Event 2019
  • SETI@Home Intel-Race II
  • BOINC Pentathlon 2020
  • THOR Challenge 2020
Wenn der Nachbar nicht gerade beim Flashen einen Stromausfall hatte, wüsste ich nicht, warum sich der Inhalt des Bios-Chips einfach so verflüchtigt hätte und nur neu geschrieben werden muss.

Was manchmal hilft, das board ohne RAM und ohne GraKa zu starten und dann nach und nach wieder bestücken. Dann erzwingt man so eine Art ausführlichere Neuerkennung von Hardware.

Die Kondensatoren sind ja alle "solid", da kann gar nichts mehr aufblähen, defekt können sie trotzdem sein. Das passiert bei Rechnern, die oft monatelange ohne Strom waren, gar nicht mal so selten. Und bei nur wenigen Betriebsstunden könnte das Board auch einfach schon einen halben Defekt bei Auslieferung gehabt haben und bei der erstbesten längeren Betriebsphase, wo alles doch mal bissel wärmer wird - ZACK - ist der Fehler manifestiert.
 

8256

Cadet
★ Themenstarter ★
Mitglied seit
21.04.2020
Beiträge
18
Renomée
5
Hallo MagicEye04,

geflashed hat er auf jeden Fall nix, er wüsst auch nicht, was das ist. Er wird bald 80 und ist schon stolz, dass er Online Banking damit macht.

Die üblichen Tests habe ich natürlich schon gemacht, auch ohne RAM verhält sich das Board gleich, daher meine Vermutung, dass hier kein BIOS (mehr) ist, was ggfs. über den Speaker ein paar Fehlercodes ausspuckt. Eine Diagnose-Karte wäre natürlich hilfreich, um das zu bestätigen.

Dass das Rechner stromlos machen die Quelle des Problems sein kann, habe ich ihm auch gesagt, er hat trotzdem wieder den Schalter an der Verteilerdose umgelegt.
Ich hatte tatsächlich nicht gewußt, dass die solid caps nicht mehr aufblähen, damit fällt natürlich die Diagnose mit dem bloßen Auge weg.

Obwohl die Diagnose-Karte auch nur um die 8 EUR kostet, weiß ich noch nicht, ob ich mir die gönne. Die liegt ja dann auch wieder ewig im Schrank und ISA und PCI Slots gibt es ja auch nicht mehr auf aktuellen Mainboards.
 

dekaisi

Grand Admiral Special
Mitglied seit
06.11.2006
Beiträge
3.930
Renomée
25
Standort
B
Ich nutze die ältere Version von Flasher regelmäßig.
Leider sind für neuer Soc auch eine neuere Version der Software nötig. Sprich für die Winbond xxxxFW mind. 1.36. Da sucht man dann schon arg im Netz.

Dennoch das ist recht einfach, auch wenn du es mit der Klammer machen kannst.
Bios File vom Hersteller und schups drauf.

Es gibt diverse Chips die degradieren und ihre Daten verlieren. Oft auch bei Getriebesteuergeräten, Kombiinsturmenten (Motorrad), da kann man es auch gut nutzen.
Genauso kann man so defekte Bios, oder andere Bios (IBM/DELL/Fujitsu) auf Seagate umflashen und Server Hardware wieder normal nutzen. ggf. Passwörter somit löschen. (Beispiel SAS SSD)

Die Software die du suchst heißt CH341A Programm v1.3x (aktuell in 1.38 )

z.B.

das schreiben ist eher einfach, gerade wenn du einen Chip mit Beinchen hast

Gibt es bei deinem Board nicht die Option Bios Flash per recovery USB-Port?
 

Anhänge

  • flasher.jpeg
    flasher.jpeg
    280,8 KB · Aufrufe: 9
  • seagte-ssd.jpg
    seagte-ssd.jpg
    461,8 KB · Aufrufe: 9
Zuletzt bearbeitet:

pipin

Administrator
Teammitglied
Mitglied seit
16.10.2000
Beiträge
21.349
Renomée
8.278
Standort
East Fishkill, Minga, Xanten
  • SIMAP Race
  • QMC Race
  • RCN Russia
  • Spinhenge ESL
  • Docking@Home
  • BOINC Pentathlon 2019
  • SETI@Home Intel-Race II
  • THOR Challenge 2020
Die üblichen Tests habe ich natürlich schon gemacht, auch ohne RAM verhält sich das Board gleich, daher meine Vermutung, dass hier kein BIOS (mehr) ist, was ggfs. über den Speaker ein paar Fehlercodes ausspuckt. Eine Diagnose-Karte wäre natürlich hilfreich, um das zu bestätigen.

Da ich gerade selbst eine Fehlersuchodyssee mit einem neueren Board und CPU hinter mir habe.

Hast du alles unnötige vom Board abgestopselt oder vielleicht sogar mal das Board ausgebaut und außerhalb des Gehäuses getestet?
 

8256

Cadet
★ Themenstarter ★
Mitglied seit
21.04.2020
Beiträge
18
Renomée
5
Hallo,

ja, hatte alles abgezogen, es war nur noch CPU, Kühler und RAM drauf. Der RAM und CPU funktionierten auf einem anderen Mainboard.
Das Mainboard habe ich inzwischen auch schon entsorgt, anscheinend ist so ein alter i3 auch schon absolut wertlos und liegt hier nur noch als Ersatzteil rum.
Daher konnte ich auch leider dekaisi´s Vorschlag nicht mehr umsetzen. Zwischen den Feiertagen war ja genug Zeit, im neuen Jahr hatte ich mich aber dann doch recht schnell davon getrennt, da es sich doch nicht lohnt hier noch Zeit und Geld zu investieren, auch wenn es eigentlich ganz interessant wäre.
Offensichtlich kann man so einen Flasher doch ganz sinnvoll einsetzen. :-)
 
Oben Unten