10 Outlook-Fehler durch AMD-Chipsatztreiber-Installer Fehler

Nero24

Administrator
Teammitglied
★ Themenstarter ★
Mitglied seit
01.07.2000
Beiträge
23.676
Renomée
9.817
  • BOINC Pentathlon 2019
  • BOINC Pentathlon 2020
  • BOINC Pentathlon 2018
  • BOINC Pentathlon 2021
Hallo zusammen,

wenn man denkt, man hat in Sachen IT-Merkwürdigkeiten schon alles erlebt in den letzten 30 Jahren, dann kommt sowas um die Ecke... *chatt*

Gestern meldet sich ein Kunde, er kann mit seinem Outlook 2016 plötzlich keine E-Mails mehr versenden. Ist ein IMAP-Konto. Empfangen funktioniert, senden dagegen quittiert Outlook mit der Meldung "Fehler bei diesem Vorgang. Die Nachrichtenschnittstellen haben einen unbekannten Fehler zurückgeliefert. Falls das Problem weiter besteht, starten Sie Outlook neu." Letzteres hilft natürlich nicht.

Nachdem ausgeschlossen war, dass es am Mailserver liegt, habe ich die Kontenkonfiguration gecheckt. Seltsamerweise funktionierte die eingebaute Konto-Testfunktion in Outlook sowohl empfangend, als auch sendend. Fehlerhafte Kontenkonfiguration (SSL, Port, Passwort, etc.) schied also auch aus. Nun muss man dazusagen, dass der Anwender seine E-Mails mit einer digitalen Signatur unterzeichnet und das führte mich nach langer Recherche zur Quelle des Übels.

Der PC ist ein AMD Ryzen 3 2200G mit Windows 10 Pro x64 v2004 und Office 2016 Standard. Und jetzt kommt's. Der AMD Chipsatz-Treiberinstaller legt in der Windows-Registry unter [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Cryptography\Providers\] anscheinend einen Schlüssel namens [AMD Provider] an und registriert dort eine DLL namens C:\Windows\system32\amdumcsp.dll die wohl irgendwelche Kryptosachen erledigen sollte. Aber: diese Datei existiert nirgendwo auf dem System. Der Installer registriert sie, versäumt dann aber wohl, sie im Systemverzeichnis abzulegen. Und wenn Outlook versucht, beim senden die E-Mail digital zu signieren, stolpert es wohl darüber und bricht dann mit dieser seltsamen Fehlermeldung ab. *suspect*

Abhilfe schafft, entweder den AMD-Chipsatztreiber erst gar nicht zu installieren und Windows-Update die Einzelkomponenten wie SM-Bus-Treiber, GPIO-Treiber, PSP-Treiber, etc. ziehen zu lassen – dann fehlen aber so Sachen wie der Ryzen-Powerplan – oder man löscht den Schlüssel [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Cryptography\Providers\AMD Provider] komplett und rebootet. Dann funktioniert's auch wieder. Warum das jetzt erst auftritt und nicht schon seit letztem Jahr, als der PC installiert wurde, kann ich auch nicht sagen. *noahnung* Womöglich signiert der Anwender erst seit kurzem. Zudem war kürzlich Update von v1903 auf v2004, was auch etwas verbogen haben könnte.

Ich werde den Bug mal bei AMD melden :] Wollte es an der Stelle nur mal erwähnt haben als Knowledge-Sammlung, falls noch jemand irgendwann das Problem hat. :)
 
Zuletzt bearbeitet:

BoMbY

Grand Admiral Special
Mitglied seit
22.11.2001
Beiträge
7.461
Renomée
281
Standort
Aachen

Dalai

Grand Admiral Special
Mitglied seit
14.06.2004
Beiträge
7.375
Renomée
241
Standort
Meiningen, Thüringen
Für mich stellt sich die Frage, warum ein Chipsatztreiber einen CSP (Crypto Service Provider) mitbringen und registrieren muss. Wo ist der Zusammenhang? Kann da jemand Erleuchtung bringen?

Grüße
Dalai
 

maikrosoft

Commodore Special
Mitglied seit
26.11.2004
Beiträge
467
Renomée
16
Standort
germany
Würde mich auch interessieren, zumal hier auf 2 Systemen, einmal 2600 und einmal 3600er, trotz installiertem Chipsatztreiber der reg Eintrag nicht existiert.
 

Nero24

Administrator
Teammitglied
★ Themenstarter ★
Mitglied seit
01.07.2000
Beiträge
23.676
Renomée
9.817
  • BOINC Pentathlon 2019
  • BOINC Pentathlon 2020
  • BOINC Pentathlon 2018
  • BOINC Pentathlon 2021
Bei meinem 2700 ist der Eintrag auch nicht da, trotz installiertem Chipsatztreiber. Vielleicht wird der Eintrag nur bei den APUs vorgenommen? Oder es war der damals bei der Einrichtung aktuellen Version geschuldet? *noahnung*
 

BoMbY

Grand Admiral Special
Mitglied seit
22.11.2001
Beiträge
7.461
Renomée
281
Standort
Aachen
Für mich stellt sich die Frage, warum ein Chipsatztreiber einen CSP (Crypto Service Provider) mitbringen und registrieren muss. Wo ist der Zusammenhang? Kann da jemand Erleuchtung bringen?

Also grundsätzlich ist das wohl eine Möglichkeit Hardwarebeschleunigung dafür einzubinden. Ich denke das mit der amdumcsp.dll ist irgendein Relikt und das wird heute irgendwie anders gemacht.
 
Oben Unten