PCIe x4 10GbE-NIC in A320 mATX-Board?

Maverick-F1

Admiral Special
★ Themenstarter ★
Mitglied seit
09.09.2002
Beiträge
1.299
Renomée
175
  • BOINC Pentathlon 2017
  • BOINC Pentathlon 2018
  • BOINC Pentathlon 2019
  • BOINC Pentathlon 2016
  • BOINC Pentathlon 2015
  • SETI@Home Wow!-Event 2019
  • SETI@Home Intel-Race II
  • BOINC Pentathlon 2020
  • THOR Challenge 2020
Ich bin dabei, mein Home-LAN von 1GbE auf 10GbE (für die Maschinen, die das brauchen) aufzurüsten.
Nach dem Switch hab' ich dazu eine ASUS XG-C100C erstanden, die eigentlich in meinen Home-Server soll. Dieser basiert auf einem MSI A320M-A-PRO (mit einem A12-9800E) und 2x4GB Ram.
Das Board hat einen PCIe 3.0 x16 PEG Slot (derzeit ungenutzt) und einen PCI 2.0 x1 Slot, in dem eine DVB-S 2 Karte verbaut ist.

Die 10GbE ASUS Karte (hat einen x4 Anschluß!) soll also in den PEG-Slot. Grundsätzlich sollte das auch funktionieren - MSI hat auch 10GbE-NICs getestet (siehe hier - leider ohne Angabe des Slots - kann aber eigentlich nur der PEG-Slot gewesen sein). Zwar mit BIOS 1.0, aber ich bezweifle, dass das aktuelle BIOS "schlechter" ist...

Lange Rede kurzer Sinn: es geht nicht :(
Der Rechner will nicht mehr wirklich booten, und der Bildschirm bliebt schwarz (DVI & HDMI - APU-GPU). Ganz tot scheint er dabei aber nicht zu sein, er reagiert noch auf Interrupts (Num-Lock-Taste).
Ich hab' noch im BIOS mit der GraKa-Erkennung rumgespielt (iGP only, no PEG-GPU, etc.), das hat die Situation eher noch verschlimmert...

Habt Ihr da evtl. noch eine Idee (außer es mit einer teuren kompatiblen Karte zu versuchen)?

Die Alternative wäre ein USB-Adapter <10GbE, was für die Maschine aktuell schnell genug wäre, aber wenn's irgendwie möglich wäre, ziehe ich eine interne Steckkarte definitiv vor!

Hab' ich evtl. was übersehen?
 

Zidane

Lt. Commander
Mitglied seit
22.07.2019
Beiträge
104
Renomée
12
Laut Handbuch shared der PEG-Slot mit APU. Je nach APU stehen dann noch x8 oder x4 zur Verfügung. Da der Chipsatz aber zu wenig Lanes hat bleibt der PEG Slot Tod. Da sollte nichtmal die TV-Karte drin laufen.

https://download.msi.com/archive/mnu_exe/mb/M7C52v1.2.pdf -> Seite 10

"Schach" Matt würde ich mal sagen ?
 

Maverick-F1

Admiral Special
★ Themenstarter ★
Mitglied seit
09.09.2002
Beiträge
1.299
Renomée
175
  • BOINC Pentathlon 2017
  • BOINC Pentathlon 2018
  • BOINC Pentathlon 2019
  • BOINC Pentathlon 2016
  • BOINC Pentathlon 2015
  • SETI@Home Wow!-Event 2019
  • SETI@Home Intel-Race II
  • BOINC Pentathlon 2020
  • THOR Challenge 2020
Hm - das versteh' ich noch nicht ganz: *kopfkratz
Laut der CB-Tabelle müsste ich mit der A12-APU und dem 320er Chipsatz ja 10 PCIe 3.0 Lanes freihaben und 4x PCIe 2.0 - richtig?
Laut Board-Doku bleiben mir von der APU dafür 8x PCIe 3.0 über - das müsste theoretisch ja auch reichen: 1x PCIe 2.0 für die DVB-Karte & 4x PCIe 3.0 (ist ja abwärtskompatibel zu 2.0) für die NIC.
Oder hab' ich da irgendwo einen Denkfehler drin? *noahnung*
Wie hätte MSI dann die freigegebenen NICs (siehe https://storage-asset.msi.com/file/test_report/TR9_16603.pdf) validiert? Nur mit einem Ryzen?

Ansonsten muss es halt ein USB-Adapter werden...
 

Crashtest

Redaktion
☆☆☆☆☆☆
Mitglied seit
11.11.2008
Beiträge
8.808
Renomée
1.109
Standort
Leipzig
  • Docking@Home
  • BOINC Pentathlon 2011
  • BOINC Pentathlon 2012
  • BOINC Pentathlon 2013
  • BOINC Pentathlon 2014
  • BOINC Pentathlon 2015
  • BOINC Pentathlon 2016
  • BOINC Pentathlon 2017
  • BOINC Pentathlon 2018
  • BOINC Pentathlon 2019
  • BOINC Pentathlon 2020
  • THOR Challenge 2020
Denkfehler!

Der PCIe 2.0 x1 Slot ist nicht vom Sockel AM4 sondern vom Chipsatz dh. A320

In der Regel hängen am Chipsatz:
- Netzwerkchip
- 1-2 PCIe x1 Slots
- ggf. auch der 2. M2 Slot (mit x2)

Der A320 bietet bis zu 4 PCIe Lanes.

Die meisten AMD APUs bieten 8 PCIe Lanes im Sockel FPx und 12 PCIe Lanes im Sockel AM4
4 Lanes für Chipsatzanbindung
8 Lanes für PCI x16 Slot oder 4 Lanes für PCIe x16 Slot und 4 Lanes für m2

Carrizo/Bristol Ridge hat im AM4 sogar ganze 16 Lanes (vgl. BKDG Fam15 Mdl. 60-6F Seite 161)
 
Zuletzt bearbeitet:

Maverick-F1

Admiral Special
★ Themenstarter ★
Mitglied seit
09.09.2002
Beiträge
1.299
Renomée
175
  • BOINC Pentathlon 2017
  • BOINC Pentathlon 2018
  • BOINC Pentathlon 2019
  • BOINC Pentathlon 2016
  • BOINC Pentathlon 2015
  • SETI@Home Wow!-Event 2019
  • SETI@Home Intel-Race II
  • BOINC Pentathlon 2020
  • THOR Challenge 2020
Dann hatte ich mich missverständlich ausgedrückt:
- 4x PCIe 2.0 vom Chipsatz - da hinge dann die DVB-S Karte dran (die nur 1x PCIe 2.0 braucht - der physikalische Slot bietet auch nur 1x)
- 8x (oder sogar 16x :o) PCIe 3.0 vom Bristol-Ridge - da hinge dann die NIC im verbleibenden PEG-Slot (wobei die Karte davon aber nur 4x PCIe 2.0 braucht)

Sollte also theoretisch funktionieren - also doch ein BIOS-Thema? (Bin auf dem aktuellsten)
 

Zidane

Lt. Commander
Mitglied seit
22.07.2019
Beiträge
104
Renomée
12
Was gibt das Bios für PEG-Slot Einstellungen her ? - Für mich ließt sich das so das nur Grafikkarten in dem Slot gehen ? - Entweder APU oder dezidierte Grafik.
 

Maverick-F1

Admiral Special
★ Themenstarter ★
Mitglied seit
09.09.2002
Beiträge
1.299
Renomée
175
  • BOINC Pentathlon 2017
  • BOINC Pentathlon 2018
  • BOINC Pentathlon 2019
  • BOINC Pentathlon 2016
  • BOINC Pentathlon 2015
  • SETI@Home Wow!-Event 2019
  • SETI@Home Intel-Race II
  • BOINC Pentathlon 2020
  • THOR Challenge 2020
Das im PEG-Slot nur Grafikkarten funktionieren soll kann eigentlich auch nicht sein, weil wie hätte MSI dann die größeren NICs validieren sollen? Das Board hat ansonsten ja nur noch den einen PCIe x1 2.0 Port... *noahnung*

Viel gibt das BIOS nicht her:
BIOS_01.jpg

BIOS_02.jpg

Mit dem 2. Setting (IGD enabled) wollte er nicht mehr...
 

Crashtest

Redaktion
☆☆☆☆☆☆
Mitglied seit
11.11.2008
Beiträge
8.808
Renomée
1.109
Standort
Leipzig
  • Docking@Home
  • BOINC Pentathlon 2011
  • BOINC Pentathlon 2012
  • BOINC Pentathlon 2013
  • BOINC Pentathlon 2014
  • BOINC Pentathlon 2015
  • BOINC Pentathlon 2016
  • BOINC Pentathlon 2017
  • BOINC Pentathlon 2018
  • BOINC Pentathlon 2019
  • BOINC Pentathlon 2020
  • THOR Challenge 2020
Muss definitiv ein BIOS Problem sein.

Ich hab nen A10-9700 auf A320 mit SAS HBA (PCIe 2.0 x4) ohne Probleme getestet.

Auch der FX8800P macht keine Probleme mit einer PCIe x4 Karte und IGP
 

tomturbo

Technische Administration, Dinosaurier
Mitglied seit
30.11.2005
Beiträge
9.127
Renomée
397
Standort
Österreich
  • SIMAP Race
  • QMC Race
  • Spinhenge ESL
  • BOINC Pentathlon 2013
  • BOINC Pentathlon 2014
  • BOINC Pentathlon 2015
  • BOINC Pentathlon 2016
  • BOINC Pentathlon 2017
  • BOINC Pentathlon 2019
  • SETI@Home Wow!-Event 2019
Ja das mit dem BIOS-Init-Problem denke ich ist es.

Ich habe hier auf einem ASUS M5A97 Evo R2.0 auch so eine ASUS Netzwerkkarte im PEG16 Slot und im 2. PEG16 Slot ein SATA Controller, allerdings als LWL, egal das ist der gleiche Chipsatz, und funktioniert.
 

Maverick-F1

Admiral Special
★ Themenstarter ★
Mitglied seit
09.09.2002
Beiträge
1.299
Renomée
175
  • BOINC Pentathlon 2017
  • BOINC Pentathlon 2018
  • BOINC Pentathlon 2019
  • BOINC Pentathlon 2016
  • BOINC Pentathlon 2015
  • SETI@Home Wow!-Event 2019
  • SETI@Home Intel-Race II
  • BOINC Pentathlon 2020
  • THOR Challenge 2020
Hm - dann muss ich da nochmal rumbasteln (ein BIOS-Downgrade is aber auch doof) - muss aber wohl bis nach dem Pentha warten (dachte eigentlich, dass das davor "schnell" geht). Aktuell steckt die Karte im Ryzen, um die Gebäuseverkabelung mal zu checken - da muss ich "nur" mal umstecken...
 

Maverick-F1

Admiral Special
★ Themenstarter ★
Mitglied seit
09.09.2002
Beiträge
1.299
Renomée
175
  • BOINC Pentathlon 2017
  • BOINC Pentathlon 2018
  • BOINC Pentathlon 2019
  • BOINC Pentathlon 2016
  • BOINC Pentathlon 2015
  • SETI@Home Wow!-Event 2019
  • SETI@Home Intel-Race II
  • BOINC Pentathlon 2020
  • THOR Challenge 2020
Update:
Heute ist die Intel X550-T2 gekommen (die Asus steckt jetzt in dem 3950X, wo sie problemlos im 2. PEG-Slot funktioniert) - und nach der Treiberinstallation lief sie sofort ohne Probleme - damit hat der Server jetzt auch endlich einen 10 GbE Link! *clap*

Manchmal sollte man sich doch strikt an die Validierungen der Hersteller halten... :]
 
Oben Unten