Ubuntu: PC bleibt beim Booten hängen nach /dev/sda: [zahlen]

sompe

Grand Admiral Special
Mitglied seit
09.02.2009
Beiträge
10.240
Renomée
611
@Woodstock
Ist zufällig eine Geforce Grafik in dem Gerät?
Mit Ubuntu 20 und meiner Geforce habe ich auch so meine Probleme. Das ließ sich idR. damit beheben die Reparaturfunktion zu starte, nach fehlerhaften Dateien zu suchen und zu reparieren, überflüssige Pakete suchen und entfernen zu lassen und den Rechner danach normal starten zu lassen oder in die Reparaturkonsole zu gehen und gleich wieder starten zu lassen.
Mit Ubuntu 18 lief es bei mir auch tadellos, Ubuntu 20 mit der zuvor verbauten alten Radeon ebenfalls aber die Geforce Treiber scheinen ziemliche Probleme zu bereiten.
Im übrigen tauchte das Problem regelmäßig nach OS Updates auf.
 

Riddler82

Leitung Moderation
Teammitglied
Mitglied seit
11.11.2001
Beiträge
9.377
Renomée
227
Standort
Bayern, am Rande des Wahnsinns
  • SIMAP Race
  • QMC Race
  • Spinhenge ESL
  • BOINC Pentathlon 2012
  • BOINC Pentathlon 2014
Jupp, liegt wohl an der nvidia Karte.
Hab heute eine 550GTX ausgegraben und in den Testrechner gesteckt.
Bei ca. 90% der Installation ein Fehler, bootet aber.
Dann den proprietären Nvidiatreiber nachinstalliert und Schwupps, blackscreen.
 

MagicEye04

Grand Admiral Special
★ Themenstarter ★
Mitglied seit
20.03.2006
Beiträge
20.046
Renomée
714
Standort
oops,wrong.planet..
  • BOINC Pentathlon 2011
  • BOINC Pentathlon 2012
  • BOINC Pentathlon 2013
  • BOINC Pentathlon 2014
  • BOINC Pentathlon 2015
  • BOINC Pentathlon 2016
  • BOINC Pentathlon 2017
  • BOINC Pentathlon 2018
  • BOINC Pentathlon 2019
  • SETI@Home Wow!-Event 2019
  • SETI@Home Intel-Race II
  • BOINC Pentathlon 2020
  • THOR Challenge 2020
  • BOINC Pentathlon 2021
Ich hatte zwar auf 2 Rechnern auch Nvidia drin - aber der 3950X hat nur den AMDGPU-pro gehabt.
Und der Rechner, der als einziger noch problemlos läuft, hat ne Geforce.
 

Riddler82

Leitung Moderation
Teammitglied
Mitglied seit
11.11.2001
Beiträge
9.377
Renomée
227
Standort
Bayern, am Rande des Wahnsinns
  • SIMAP Race
  • QMC Race
  • Spinhenge ESL
  • BOINC Pentathlon 2012
  • BOINC Pentathlon 2014
Sagen wir es anders, der Fehler scheint gern in Zusammenhang mit proprietären Treibern aufzutreten.

Ich konnte den Rechner mit der 550GTX übrigens mit der Methode von sompe zum Booten bewegen:
In den recovery mode, pakete mit der "dpgk" Option reparieren, dann den Bootvorgang mit "resume" fortsetzen. Bzw. Ich musste dann nochmal vom Recoverymodus aus den Bootvorgang mit "resume" fortsetzen.
Der normale Bootvorgang klappt aber immer noch nicht, ich muss jedesmal über die recovery -> resume gehen. *abgelehnt

Mit dem quelloffenen Nvidiatreiber läuft alles normal. Fürs erste bleib ich da wohl bei der 18.04.
 

MagicEye04

Grand Admiral Special
★ Themenstarter ★
Mitglied seit
20.03.2006
Beiträge
20.046
Renomée
714
Standort
oops,wrong.planet..
  • BOINC Pentathlon 2011
  • BOINC Pentathlon 2012
  • BOINC Pentathlon 2013
  • BOINC Pentathlon 2014
  • BOINC Pentathlon 2015
  • BOINC Pentathlon 2016
  • BOINC Pentathlon 2017
  • BOINC Pentathlon 2018
  • BOINC Pentathlon 2019
  • SETI@Home Wow!-Event 2019
  • SETI@Home Intel-Race II
  • BOINC Pentathlon 2020
  • THOR Challenge 2020
  • BOINC Pentathlon 2021
Das mit Resume klappte bei mir leider gar nicht. Ich hatte so ziemliches alles im Recovery-Menu durchprobiert.
Aktuell habe ich dem 3950X noch keinen extra Grafiktreiber verpasst. Probier ich nach dem THOR-Event noch mal mit AMDGPU-pro. Wenn das wieder Probleme macht, muss ich eben doch nur einzeln den OpenCL-Teil installieren.
 

Krümel

Grand Admiral Special
Mitglied seit
19.08.2003
Beiträge
4.740
Renomée
223
Standort
Schleswig-Holstein
  • Spinhenge ESL
  • Docking@Home
  • BOINC Pentathlon 2011
  • BOINC Pentathlon 2012
  • BOINC Pentathlon 2013
  • BOINC Pentathlon 2014
  • BOINC Pentathlon 2016
  • BOINC Pentathlon 2017
  • BOINC Pentathlon 2018
  • BOINC Pentathlon 2019
  • SETI@Home Wow!-Event 2019
  • SETI@Home Intel-Race II
  • BOINC Pentathlon 2020
  • THOR Challenge 2020
  • BOINC Pentathlon 2021
Ich hatte meinen Rechner von 18.04 auf 20.04 geupdatet. Der hat eine GTX 1050 drin.
Lief nicht ganz problemlos, so musste ich die Aktualisierungsverwaltung noch nachinstallieren, neben 600 anderen Paketen...
Aber beim booten gab es nie Probleme.
 

sompe

Grand Admiral Special
Mitglied seit
09.02.2009
Beiträge
10.240
Renomée
611
Ich nutze nur den empfohlenen Treiber de Ubuntu selbst anbietet.
 

Riddler82

Leitung Moderation
Teammitglied
Mitglied seit
11.11.2001
Beiträge
9.377
Renomée
227
Standort
Bayern, am Rande des Wahnsinns
  • SIMAP Race
  • QMC Race
  • Spinhenge ESL
  • BOINC Pentathlon 2012
  • BOINC Pentathlon 2014
Genau den hatte ich auch genommen, den proprietären, von Ubuntu empfohlenen. Damit gab es dann die Bootprobleme, der freie Treiber funktioniert.
 

sompe

Grand Admiral Special
Mitglied seit
09.02.2009
Beiträge
10.240
Renomée
611
Ist beim freien Treiber auch OpenCL verfügbar?
Die 1030 ist zwar etwas schwach auf der Brust aber besser als nix. ;D
 

sompe

Grand Admiral Special
Mitglied seit
09.02.2009
Beiträge
10.240
Renomée
611
Ich habe heute mal bei meinem Ripper Cruncher die Updates durchlaufen lassen und dabei wurde auch gleich auf den 450er Geforce Treiber als empfohlener Treiber gewechselt.
Bisher lief er auch nach mehreren Reboots einwandfrei.
Nun wurde mir auch erstmals bei meinem 3950X das Upgrade auf Ubuntu 20 angeboten.
 

vnt

Lt. Commander
Mitglied seit
02.12.2011
Beiträge
122
Renomée
11
... muss ich eben doch nur einzeln den OpenCL-Teil installieren.

Hallo MagicEye04,

ich betreibe die Kombination von Mesa-Standardgrafikkartentreiber und OpenCL aus dem AMD-Treiberpaket 20.40 (amdgpu-pro-20.40-1147286-ubuntu-20.04.tar.xz) auf einem Ryzen 5 3600 mit Radeon RX 560 unter Linux Mint 20 für die Verwendung von OpenCL in Darktable: läuft ohne Probleme.

Wenn Du das ausprobieren möchtest benötigst Du aus dem vorgenannten Treiberpaket lediglich die nachstehenden Teilpakete, die Du in der angegebenen Reihenfolge installieren musst:

  1. amdgpu-core_20.40-1147286_all.deb
  2. amdgpu-pro-core_20.40-1147286_all.deb
  3. libdrm2-amdgpu_2.4.100-1147286_amd64.deb
  4. libdrm-amdgpu-common_1.0.0-1147286_all.deb
  5. libdrm-amdgpu-amdgpu1_2.4.100-1147286_amd64.deb
  6. opencl-orca-amdgpu-pro-icd_20.40-1147286_amd64.deb
  7. ocl-icd-libopencl1-amdgpu-pro_20.40-1147286_amd64.deb
  8. clinfo-amdgpu-pro_20.40-1147286_amd64.deb
... dann sollte OpenCL funktionieren.

Gruß,
vnt
 

Woodstock

Grand Admiral Special
Mitglied seit
04.05.2002
Beiträge
9.306
Renomée
97
Standort
Somewhere in Oberfranken
@Woodstock
Ist zufällig eine Geforce Grafik in dem Gerät?
Mit Ubuntu 20 und meiner Geforce habe ich auch so meine Probleme. Das ließ sich idR. damit beheben die Reparaturfunktion zu starte, nach fehlerhaften Dateien zu suchen und zu reparieren, überflüssige Pakete suchen und entfernen zu lassen und den Rechner danach normal starten zu lassen oder in die Reparaturkonsole zu gehen und gleich wieder starten zu lassen.
Mit Ubuntu 18 lief es bei mir auch tadellos, Ubuntu 20 mit der zuvor verbauten alten Radeon ebenfalls aber die Geforce Treiber scheinen ziemliche Probleme zu bereiten.
Im übrigen tauchte das Problem regelmäßig nach OS Updates auf.

Sorry für das späte Feedback.

Eine Geforce ist im H920 nicht verbaut. Aber eine Nvidoa Quadro K3000M

Aber wie gesagt. Es lag bei mir am USB stick. Inzwischen läufts ja. Sogar die beiden 4K Monitore die ich am Lenovo USB-C Hybrid Dock angeschlossen habe kann ich ansteuern :)
Nur das mit dem skalieren klappt nicht ganz so gut wie unter Windows mit den 2x 4k und FullHD Displays :) Auf den beiden 4K ist alles recht .... klein :)
 
Oben Unten