Neue M.2 PCIe 3.1-SSD funktioniert nicht in M.2 PCIe "Gen3" Slots

Eye-Q

Grand Admiral Special
Mitglied seit
01.10.2003
Beiträge
7.208
Renomée
415
Standort
Hamburch
Moin,

Update 14.12.: ich habe mir jetzt eine Kingston NV2 (PCIe 4) geholt, die funktioniert im B450 Pro4...

Update 01.12. um 13:00h: so wie es aussieht funktioniert die SSD wirklich nicht in meinem Mainboard, da die in einem Notebook bei meinem Arbeitgeber erkannt wird, initialisiert werden kann etc... :[

ich habe mir eine KIOXIA EXCERIA G2 NVMe-SSD (PCIe Gen 3.1 x4) mit 2 TB gekauft, um eine HDD abzulösen. Leider wird die neue SSD in keinem der beiden M.2-Slots meines ASRock B450 Pro4 (nicht R2.0, UEFI Version 5.00) mit Ryzen 5 5600G erkannt, noch nicht mal im UEFI. Im ersten ("Ultra M.2" oder M2_1, PCIe Gen3 x4) steckt aktuell eine Kingston A2000 mit 500 GB (PCIe Gen 3.0 x4), die funktioniert in beiden Slots. Der zweite Slot (M2_2) kann laut Handbuch und ASRock-Website sowohl mit PCIe Gen3 x2 als auch mit SATA betrieben werden, da gibt es aber keine Einstellung im UEFI, sondern das sollte wohl automatisch erkannt werden, ob eine NVMe- oder SATA-SSD eingesteckt wurde.
Ich hatte auch mal alle anderen angeschlossenen Massenspeichergeräte (SATA-SSD an Port SATA3_1, SATA-HDD an Port SATA3_2 und eben die Kingston A2000) entfernt und nur die KIOXIA-SSD in M2_1 gesteckt, da wurde im UEFI gar kein Massenspeicher erkannt. Auch ein UEFI-Reset habe ich schon durchgeführt.

Ja, ich weiß, dass der PCIe-Slot 4 deaktiviert wird, wenn M2_1 verwendet wird, den PCIe-Slot verwende ich auch nicht, genauso weiß ich, dass SATA3_3 und SATA3_4 sich Lanes mit M2_2 teilen, deswegen habe ich an SATA3_3 und SATA3_4 nichts angeschlossen. :) Auch dass die KIOXIA-SSD im zweiten Slot nicht die volle Leistungsfähigkeit entfalten kann weiß ich, das Ding soll aber reiner Massenspeicher sein, da ist es mir wurscht, ob das Ding 1,8 oder 2,1 GB/s sequenziell lesen kann. ;)

Hat das Mainboard vielleicht ein Problem mit dem PCIe 3.1-Interface der SSD? Normalerweise sollten sowohl Slot als auch SSD ab- und aufwärtskompatibel sein, so dass die sich auf den kleinsten gemeinsamen Nenner einigen sollten, oder?
 
Zuletzt bearbeitet:
Moin @Eye-Q, nach einem kurzen Blick auf die M2 Support Liste bei Asrock sind dort so garkeine Kioxia M2 drin. Die Listen sind ja meist nicht immer aktuell wenn‘s mit neueren Bios Versionen (ist deines aktuell?) auch nicht geht, wird’s wohl an Asrock liegen. Eventuell mal Support anschreiben oder andere M2 holen ;)

Grüße 🖖🏼
 
Also ich finde in der Liste insgesamt sechs KIOXIA-SSDs, bei den M.2 PCIe-SSDs aber nur die teuren EXCERIA G2 Plus, die mal eben 230 statt 130 Euro für 2 TB kostet...

Ich werde wohl nach einer anderen M.2-SSD Ausschau halten...
 
Gerade NVMe sind leider zickig.

Mein Gigabyte mochte keine Samsung OEM (lief, aber ständig ist sie ausgefallen auf einem anderen Board lief sie ohne Probleme), läuft aber problemlos mit einer anderen NVMe.

Mein Asrock X470 Master SLI hatte Probleme mit einer Crucial P1 (wurde nach einem Neu- oder Kaltstart nicht erkannt)
 
Ich hatte mal mit einer Samsung SSD auch ein seltsames verhalten:

Vieleicht ist das ein ähnlich gelagertes Problem. Haast Du mal bei Kioxia gschaut wegen Update?
 
Ein Update: ich habe die KIOXIA-SSD zurückgeschickt und mir jetzt eine Kingston NV2 (PCIe 4) geholt, die funktioniert im B450 Pro4 im PCIe 3.0 x2-Slot. Da das eine reine Daten-SSD ist, ist mir völlig wumpe, dass das Ding keinen DRAM-Cache hat und vom Slot limitiert wird...
 
Kanngs ja mal prüfen ob das Überraschungsei MV2 mit TLC oder QLC bestückt ist.
 
Das würde ich gerne machen, allerdings weiß ich nicht wie... *chatt*

Die Chips sind natürlich mit einem einzigen großen Aufkleber überklebt, den will ich nicht entfernen (Gewährleistung und so).

Laut gh.de soll da ein Phison-Controller verbaut sein, das einzige Tool zum Auslesen, das ich gefunden habe (Phison Flash ID), meint aber "Identify data empty - drive not detected!". Gibt es ein anderes Tool, mit dem ich das prüfen könnte?
 
Wie geschrieben, die Leistung ist mir völlig wurscht, da das Teil als reines Datengrab verwendet wird. Die 640 TBW werde ich selbst in fünf Jahren wahrscheinlich nicht annähernd erreichen, und am Stück werde ich vielleicht mal 3-4 GB schreiben, wenn überhaupt. Ob das nun in zwei oder in 20 Sekunden geschieht ist mir da völlig wumpe.
 
Zurück
Oben Unten