Feedback für XenForo 2.2.1

BoMbY

Grand Admiral Special
Mitglied seit
22.11.2001
Beiträge
7.457
Renomée
281
Standort
Aachen
Da der passende Thread steht, hier ein Problem von mir:
Seit dem Update läuft das Forum hakeliger bzw. störend zäher, da manche Elemente wie Benutzerbilder erst verzögert (circa. eine halbe Sekunde) angezeigt werden.

Die haben da scheinbar irgendeine sehr merkwürdige "Lazy Loading"-Geschichte eingebaut. Wirkt in der Tat sehr seltsam.
 

pipin

Administrator
Teammitglied
★ Themenstarter ★
Mitglied seit
16.10.2000
Beiträge
22.065
Renomée
8.673
Standort
East Fishkill, Minga, Xanten
  • SIMAP Race
  • QMC Race
  • RCN Russia
  • Spinhenge ESL
  • Docking@Home
  • BOINC Pentathlon 2019
  • SETI@Home Intel-Race II
  • THOR Challenge 2020
  • BOINC Pentathlon 2021
Die haben da scheinbar irgendeine sehr merkwürdige "Lazy Loading"-Geschichte eingebaut. Wirkt in der Tat sehr seltsam.

Hm, also ich merke nichts.

Kann auch nichts dazu im Supportforum finden.

Die Luxxer, CBase und PCGH haben imo alle noch nicht auf XenForo 2.2.x upgedatet.
 

MagicEye04

Grand Admiral Special
Mitglied seit
20.03.2006
Beiträge
20.197
Renomée
767
Standort
oops,wrong.planet..
  • BOINC Pentathlon 2011
  • BOINC Pentathlon 2012
  • BOINC Pentathlon 2013
  • BOINC Pentathlon 2014
  • BOINC Pentathlon 2015
  • BOINC Pentathlon 2016
  • BOINC Pentathlon 2017
  • BOINC Pentathlon 2018
  • BOINC Pentathlon 2019
  • SETI@Home Wow!-Event 2019
  • SETI@Home Intel-Race II
  • BOINC Pentathlon 2020
  • THOR Challenge 2020
  • BOINC Pentathlon 2021
Seit ich mein Notebook auf 1,5GHz festgetackert habe und bei der THOR-Challenge mitrechnen lasse, habe ich übrigens auch Ladezeiten von 1-2 Sekunden für die Bilder. Also vielleicht ist da auch einfach nur der verwendete Rechner zu schwach. ;)
 

BoMbY

Grand Admiral Special
Mitglied seit
22.11.2001
Beiträge
7.457
Renomée
281
Standort
Aachen
Die haben da scheinbar irgendeine sehr merkwürdige "Lazy Loading"-Geschichte eingebaut. Wirkt in der Tat sehr seltsam.

Hm, also ich merke nichts.

Kann auch nichts dazu im Supportforum finden.

Die Luxxer, CBase und PCGH haben imo alle noch nicht auf XenForo 2.2.x upgedatet.

Vielleicht ist das auch Browser-abhängig, oder so. Also im Firefox habe ich jedenfalls den Effekt dass Benutzer- und Signaturbilder merkbar verzögert geladen werden, und zwar triggert das scheinbar erst wenn man das in den sichtbaren Bereich scrolled.
 

Riddler82

Leitung Moderation
Teammitglied
Mitglied seit
11.11.2001
Beiträge
9.377
Renomée
227
Standort
Bayern, am Rande des Wahnsinns
  • SIMAP Race
  • QMC Race
  • Spinhenge ESL
  • BOINC Pentathlon 2012
  • BOINC Pentathlon 2014
Nuja, wenn ich mir den Seitenquelltext so ansehe:
<img src="/data/avatars/s/1/1882.jpg?1596828194" alt="Riddler82" class="avatar-u1882-s" width="48" height="48" loading="lazy" />
Aha, da haben wir's ja.

Firefox hat seit Version 75 (nightly) oder so eine Unterstützung für das loading="lazy" Tag, entweder wurde die Unterstützung mit einem der letzten Updates in Firefox überall aktiviert oder XenForo hat es tatsächlich jetzt erst implementiert. Oder beides...

Ich kann das "aufploppen" übrigens auch erkennen, aber nur, wenn ich ganz schnell nach unten scrolle.

Was kann man nun machen?
  1. Resignation
  2. XenForo umbauen
  3. Browser umbauen
Meine bevorzugte Lösung: 3. Wie? So:
  1. about:config
  2. "dom.image-lazy-loading.enabled" -> "false"
  3. ???
  4. Profit.
Kannst das mal testen, @BoMbY ?
 
Zuletzt bearbeitet:

TiKu

Administrator
Teammitglied
Mitglied seit
16.11.2001
Beiträge
21.517
Renomée
1.139
Standort
Unterföhring
  • SIMAP Race
  • QMC Race
  • Spinhenge ESL
  • Docking@Home
  • BOINC Pentathlon 2021
Chrome beherrscht das Lazy-Loading meines Wissens auch, aber da ist es anscheinend etwas anders implementiert, zumindest kann ich da keine Verzögerung feststellen.
 

Frosdedje

Fleet Captain Special
Mitglied seit
17.06.2011
Beiträge
325
Renomée
195
Standort
Im Kino
Meine bevorzugte Lösung: 3. Wie? So:
  1. about:config
  2. "dom.image-lazy-loading.enabled" -> "false"
  3. ???
  4. Profit.
Ich probiere das mal aus. :)

Edit: Mit diesen Einstellungen wird das verzögerte Nachladen hier auf der Seite und Forum tatsächlich deutlich entschärft.
 
Zuletzt bearbeitet:

pipin

Administrator
Teammitglied
★ Themenstarter ★
Mitglied seit
16.10.2000
Beiträge
22.065
Renomée
8.673
Standort
East Fishkill, Minga, Xanten
  • SIMAP Race
  • QMC Race
  • RCN Russia
  • Spinhenge ESL
  • Docking@Home
  • BOINC Pentathlon 2019
  • SETI@Home Intel-Race II
  • THOR Challenge 2020
  • BOINC Pentathlon 2021
Vielleicht ist das auch Browser-abhängig, oder so. Also im Firefox habe ich jedenfalls den Effekt dass Benutzer- und Signaturbilder merkbar verzögert geladen werden, und zwar triggert das scheinbar erst wenn man das in den sichtbaren Bereich scrolled.

Anscheinend scheint es da bei Firefox einen Bug zu geben:

If your forum has threads with many pictures, .... a known bug in Firefox where scrolling the thread the images only load as enter the view port and not before as they should.
 

pipin

Administrator
Teammitglied
★ Themenstarter ★
Mitglied seit
16.10.2000
Beiträge
22.065
Renomée
8.673
Standort
East Fishkill, Minga, Xanten
  • SIMAP Race
  • QMC Race
  • RCN Russia
  • Spinhenge ESL
  • Docking@Home
  • BOINC Pentathlon 2019
  • SETI@Home Intel-Race II
  • THOR Challenge 2020
  • BOINC Pentathlon 2021
Kann man das selbst wieder individuell ausschalten/einklappen?
Die aktuell unter diesem Thread stehenden 5 Themen sind nicht mal ansatzweise ähnlich.
Ich mag solche untergejubelte KI nicht, vor allem wenn sie komplett daneben liegt.

Kleines Update. Eine Funktion, um das selbst in den Einstellungen ein- und ausschalten zu können ist testweise schon funktionabel.
 

pipin

Administrator
Teammitglied
★ Themenstarter ★
Mitglied seit
16.10.2000
Beiträge
22.065
Renomée
8.673
Standort
East Fishkill, Minga, Xanten
  • SIMAP Race
  • QMC Race
  • RCN Russia
  • Spinhenge ESL
  • Docking@Home
  • BOINC Pentathlon 2019
  • SETI@Home Intel-Race II
  • THOR Challenge 2020
  • BOINC Pentathlon 2021
- Unter den Themen werden jetzt ähnliche Themen angezeigt.
Kann man das selbst wieder individuell ausschalten/einklappen?
Die aktuell unter diesem Thread stehenden 5 Themen sind nicht mal ansatzweise ähnlich.
Ich mag solche untergejubelte KI nicht, vor allem wenn sie komplett daneben liegt.

Für mich wäre es ja eigentlich optimal, wenn jeder die Widgets (ist auch eins) so kontrollieren könnte, wie er will.
Fänd ich auch klasse. Ich mag solche Vorschläge auch nicht. Hatte ich schon gepostet, war aber im ersten Thread zur neuen Forensoftware.

Es sind jetzt wesentlich mehr Benachrichtigungen bei der Glocke hinterlegt. Vorher waren es nur ein/zwei und nicht sonderlich alt. Vielleicht ist die Darstellung deshalb träger?!

Gruß
Ritschie

Unter

gibt es jetzt die Einstellung "Ähnliche Themen anzeigen".

Wenn ihr da den Haken rausnehmt, dann seid ihr die Anzeige los.
 

Ritschie

Moderator (DC)
☆☆☆☆☆☆
Mitglied seit
30.12.2010
Beiträge
4.164
Renomée
909
Standort
/home
  • BOINC Pentathlon 2011
  • BOINC Pentathlon 2012
  • BOINC Pentathlon 2013
  • BOINC Pentathlon 2014
  • BOINC Pentathlon 2015
  • BOINC Pentathlon 2016
  • BOINC Pentathlon 2017
  • BOINC Pentathlon 2018
  • BOINC Pentathlon 2019
  • BOINC Pentathlon 2020
  • THOR Challenge 2020
  • BOINC Pentathlon 2021

pipin

Administrator
Teammitglied
★ Themenstarter ★
Mitglied seit
16.10.2000
Beiträge
22.065
Renomée
8.673
Standort
East Fishkill, Minga, Xanten
  • SIMAP Race
  • QMC Race
  • RCN Russia
  • Spinhenge ESL
  • Docking@Home
  • BOINC Pentathlon 2019
  • SETI@Home Intel-Race II
  • THOR Challenge 2020
  • BOINC Pentathlon 2021
Das markieren der einzelnen Unterforen als gelesen durch Doppelklick auf das Symbol davor funktioniert nun auch wieder.
 
Oben Unten